Apache Cordova
  1. Apache Cordova
  2. CB-12

Error loading assets/www/index.html on extra large Callback Projects

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Invalid
    • Affects Version/s: 1.1.0
    • Fix Version/s: 1.7.0
    • Component/s: Android
    • Labels:
      None
    • Environment:

      All Android

      Description

      Steps to reproduce:
      1. Create a large Callback Android project
      2. Run Large Android Project

      Expected: App should load

      What Happens: Application shows error saying it can't load index.html

      This is caused by relying on assets that need to be unzipped to be accessed. We may want to do the unzipping into the application's jail before we access loadUrl to get around this bottleneck. This will happen only on the first load of Callback, but we currently can't style this error. Alternatively, we could somehow catch the error and call loadUrl again once index.html exists.

        Issue Links

          Activity

          Pamela Fox added a comment -

          Can you clarify what a "large" project is? I recently experienced this issue (DroidGap - Timeout error) on first load of my project, while using the latest code from github, and I would love to know what makes a project large to see if that's why I'm getting it. Thanks!

          Joe Bowser added a comment -

          This is related to the timeout on the PhoneGap loading class. This is more of a documentation issue than an acutal bug. We currently wait about 20 seconds at most to load the app. If we can't get the app loaded in 20 seconds, we call the whole thing off and say that we've timed out. This isn't technically true, since the files are locally stored. Instead, the browser is taking too long loading a large PhoneGap application.

          I'm going to assign this one to myself and set the milestone to 2.0

          Pamela Fox added a comment -

          In case it's of use to other people who find this post, I believe my long loading time was due to sending off an XMLHttpRequest before deviceready. (Discussed further in this forum post: https://groups.google.com/group/phonegap/browse_thread/thread/1abf2d47fb6216b6/d6fc7d7455badd70?#d6fc7d7455badd70)
          I don't think I've received the timeout since fixing that.

          Joe Bowser added a comment -

          This depends on CB-190

          Joe Bowser added a comment -

          This isn't actually an error, this can be worked around by changing the timeout variable, but this needs to be documented better somehow.

          Martin de Keijzer added a comment -

          Joe, can you add to this ticket how to add the variable in Cordova user-space?


            People

            • Assignee:
              Joe Bowser
              Reporter:
              Joe Bowser
            • Votes:
              1 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development