Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Works for Me
    • Affects Version/s: cordova@7.0.0
    • Fix Version/s: None
    • Labels:
      None

      Description

      When using the _blank option, the cordova plugin now crash the entire application on Android 6 and 7 after updating to the last SDK available of Google:

      Fabric tells me this :

      Fatal Exception: android.content.res.Resources$NotFoundException: Resource ID #0x0
             at android.content.res.ResourcesImpl.getValue(ResourcesImpl.java:202)
             at android.content.res.Resources.getDrawable(Resources.java:1639)
             at android.content.res.Resources.getDrawable(Resources.java:1611)
             at org.apache.cordova.inappbrowser.InAppBrowser$6.run(InAppBrowser.java:637)
             at android.app.Activity.runOnUiThread(Activity.java:6030)
             at org.apache.cordova.inappbrowser.InAppBrowser.showWebPage(InAppBrowser.java:852)
             at org.apache.cordova.inappbrowser.InAppBrowser$1.run(InAppBrowser.java:207)
             at android.os.Handler.handleCallback(Handler.java:751)
             at android.os.Handler.dispatchMessage(Handler.java:95)
             at android.os.Looper.loop(Looper.java:154)
             at android.app.ActivityThread.main(ActivityThread.java:6692)
             at java.lang.reflect.Method.invoke(Method.java)
             at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:1468)
             at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:1358)
      

      I tried with _system : No Crash, but every time I use _blank, the app crashed.
      It happens since I updated my google sdk (I think it was the play services, but not sure about this)

      Thanking you in advance

        Activity

        bowserj Joe Bowser added a comment -

        I haven't been able to reproduce this issue. This issue could have been caused by the resources being missing on installation, so I would check the resource directory if you're still having this problem. Also, please try the latest version of this plugin.

        Nikita Matrosov Nikita Matrosov added a comment -

        thibaut, Could not reproduce it with the following list of dependencies in build.gradle:

        dependencies {
            compile 'com.google.android.gms:play-services:11.0.2'
            compile fileTree(dir: 'libs', include: '*.jar')
        
            // SUB-PROJECT DEPENDENCIES START
            debugCompile(project(path: "CordovaLib", configuration: "debug"))
            releaseCompile(project(path: "CordovaLib", configuration: "release"))
            // SUB-PROJECT DEPENDENCIES END
        }
        

        But according to the stack trace, a plugin could not find 'ic_action_previous_item' icon which is used with '_blank' target. There is a list of folders where this icon should be (https://github.com/apache/cordova-plugin-inappbrowser/blob/master/plugin.xml#L92-L95).

        thibaut thibaut added a comment -

        Any news ? I am still having the issue, thanks !


          People

          • Assignee:
            Unassigned
            Reporter:
            thibaut thibaut
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development