Uploaded image for project: 'Apache Cordova'
  1. Apache Cordova
  2. CB-12633

Error when trying to add cordova-android@6.2.0

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      I attempted to upgrade my cordova-android version from 6.1.2 to 6.2.0. When I run cordova platform add android@6.2.0.

      "Error: cordovaProject.projectConfig.getFileResources is not a function"

      Switching back to 6.1.2 seems to be the only solution for the moment. I have added a stackoverflow posting here:

      http://stackoverflow.com/questions/43195668/cordova-error-using-cordova-android-6-2-0-getfileresources-is-not-a-function

        Activity

        Hide
        jcesarmobile jcesarmobile added a comment -

        I think 6.2.0 had a bug and was unpublished, can you try with 6.2.1?

        Show
        jcesarmobile jcesarmobile added a comment - I think 6.2.0 had a bug and was unpublished, can you try with 6.2.1?
        Hide
        jacquesdev Jacques de Villiers added a comment -

        Hi, yes that seems to have fixed the issue. It did complain that my grade path was not set, but just followed this guide, and seemed to work. https://gradle.org/install#with-homebrew.

        Thanks!

        Show
        jacquesdev Jacques de Villiers added a comment - Hi, yes that seems to have fixed the issue. It did complain that my grade path was not set, but just followed this guide, and seemed to work. https://gradle.org/install#with-homebrew . Thanks!
        Hide
        jcesarmobile jcesarmobile added a comment -

        Fixed in 6.2.1

        Show
        jcesarmobile jcesarmobile added a comment - Fixed in 6.2.1
        Hide
        NozFX RIchard Norris added a comment -

        @jcesarmobile - updating to 6.2.1 on windows 10 machine does not solve the issue for myself. I uninstalled and re-installed cordova version 6.5.0 and then add android platform version 6.2.1 and the same error occurs. Not sure if I'm missing anything else but I've had to fallback to 6.1.2.

        Show
        NozFX RIchard Norris added a comment - @jcesarmobile - updating to 6.2.1 on windows 10 machine does not solve the issue for myself. I uninstalled and re-installed cordova version 6.5.0 and then add android platform version 6.2.1 and the same error occurs. Not sure if I'm missing anything else but I've had to fallback to 6.1.2.

          People

          • Assignee:
            Unassigned
            Reporter:
            jacquesdev Jacques de Villiers
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development