Uploaded image for project: 'Apache Cordova'
  1. Apache Cordova
  2. CB-12122

Incompatible plugin should make the build fail, not be skipped silently

    XMLWordPrintableJSON

    Details

      Description

      When compiling (on Phonegap Build) a project containing a plugin which Cordova's version is incompatible, the plugin is silently skipped and the build is successful. Of course the functionalities of the plugin won't work in the app. Eg, here's what I got when compiling phonegap-plugin-push with Cordova 6.3.0:

      Fetching plugin "phonegap-plugin-push@1.9.0" via npm
      Installing "phonegap-plugin-push" at "1.9.0" for android
      Plugin doesn't support this project's cordova version. cordova: 6.3.2, failed version requirement: >=6.4.0
      Skipping 'phonegap-plugin-push' for android

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                user165537 165537
              • Votes:
                0 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated: