Apache Cordova
  1. Apache Cordova
  2. CB-1195

Applications will crash on EXC_BAD_ACCESS if user taps top status bar while contents of a -webkit-overflow-scrolling: touch element are modified

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Duplicate
    • Affects Version/s: 1.6.1
    • Fix Version/s: Master
    • Component/s: iOS
    • Labels:
      None
    • Environment:

      iPod Touch iOS 5.1 Hardware, iPhone 4 iOS 5.0.1 Hardware. No luck reproducing with simulator

      Description

      Hello devs,

      I have found an issue where a Cordova application will crash if the user taps the clock or battery portion of the status bar while the contents of an HTML element with -webkit-overflow-scrolling: touch are removed and rebuilt. I will attach a sample project (built with Cordova 1.6.1) which makes it easy to repro the issue. Here are the repro steps:

      • Build and launch the attached project on a device
      • Click the "Regenerate" link
      • Immediately start rapidly clicking on the clock in the top status bar
      • Repeat until crash

      In my tests the crash consistently happens on the first or second try. Note that the JavaScript in the sample project is intentionally inefficient, in an attempt to simulate a much more complicated DOM being created and destroyed.

      Enabling Zombies yields the following error:
      2012-08-04 15:59:32.837 cordovacrash[24214:707] *** -[UIWebOverflowScrollView _viewDelegate]: message sent to deallocated instance 0x605ef80

      Googling for that error revealed two threads on StackOverflow with similar issues, but this seems to be the first concrete method reproducing the issue. I created another test project which took the same javascript and placed it in a UIWebKitView without Cordova, and I could not get the application to crash. this leads me to believe that something in the Cordova framework is to blame. While my test is on an older Cordova version (1.6.1), the threads on StackOverflow mentioned builds as new as 1.9.0

      See:
      http://stackoverflow.com/questions/11382476/phonegap-ios-exception-uiweboverflowscrollview-viewdelegate-message-sent-t
      http://stackoverflow.com/questions/10378946/uiweboverflowscrollview-exception-in-phonegap-application

      Thanks!

      1. cordovacrash.zip
        1.31 MB
        Neale Genereux

        Issue Links

          Activity

          Neale Genereux added a comment - - edited

          Sample project which makes it easy to reproduce the issue. Built with 1.6.1

          Shazron Abdullah added a comment -

          Dupe of CB-1184. Linked for tracking and sample project. Further discussion should occur in that issue.


            People

            • Assignee:
              Shazron Abdullah
              Reporter:
              Neale Genereux
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development