Uploaded image for project: 'Apache Cordova'
  1. Apache Cordova
  2. CB-11251

Gradle version 2.10 is required. Current version is 2.2.1

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Labels:
    • Environment:

      OSX

      Description

      When I try and run "cordova build" I run in this known gradle issue.

      There is no possible fix other than to keep changing the version in Android studio under File -> Project Structure -> Project -> Gradle Version -> 2.10 instead of 2.22

      Every time I make a change to the common www html file, I have to go back into Android Studio and make that gradle change, rebuild then run into the emulator.

      This is out of the box, and I believe many people are having the same issue.

      "cordova build
      ANDROID_HOME=/www/Android/sdk
      JAVA_HOME=/Library/Java/JavaVirtualMachines/jdk1.8.0_45.jdk/Contents/Home

      FAILURE: Build failed with an exception.

      • Where:
        Build file '/path/MyApp/platforms/android/build.gradle' line: 22
      • What went wrong:
        A problem occurred evaluating root project 'android'.
        > Failed to apply plugin [id 'android']
        > Gradle version 2.10 is required. Current version is 2.2.1. If using the gradle wrapper, try editing the distributionUrl in /path/MyApp/gradle/wrapper/gradle-wrapper.properties to gradle-2.10-all.zip
      • Try:
        Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.

      BUILD FAILED"

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              electroteque@gmail.com Daniel Rossi
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: