Cayenne
  1. Cayenne
  2. CAY-1705

Cayenne plugin compatibility with M2E

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 3.1B1
    • Component/s: Non-GUI Tools
    • Labels:
      None

      Description

      With M2E (Maven Eclipse plugin) version 1.1 it is possible to integrate any maven plugin with it. See http://wiki.eclipse.org/M2E_compatible_maven_plugins
      Basically it lets Eclipse know when certain maven plugin should be executed.

      1. CAY-1705.patch
        0.9 kB
        Andrei Veprev

        Activity

        Hide
        Andrei Veprev added a comment -

        Patch

        Show
        Andrei Veprev added a comment - Patch
        Hide
        Andrei Veprev added a comment -

        There is no m2e version 1.1 releas yet, but you can install the lastest milestone from repo http://download.eclipse.org/technology/m2e/milestones/1.1

        Show
        Andrei Veprev added a comment - There is no m2e version 1.1 releas yet, but you can install the lastest milestone from repo http://download.eclipse.org/technology/m2e/milestones/1.1
        Hide
        Andrus Adamchik added a comment -

        Applied the patch. Can't test it yet though... All repositories listed here http://wiki.eclipse.org/M2E_updatesite_and_gittags are giving me 404 at the moment. Maybe Eclipse servers are under maintenance or something?

        Show
        Andrus Adamchik added a comment - Applied the patch. Can't test it yet though... All repositories listed here http://wiki.eclipse.org/M2E_updatesite_and_gittags are giving me 404 at the moment. Maybe Eclipse servers are under maintenance or something?
        Hide
        Andrei Veprev added a comment -

        Did you try to feed eclipse with a link such as http://download.eclipse.org/technology/m2e/milestones/1.1
        I thing this that eclipse repos simply don't have any index page.

        Show
        Andrei Veprev added a comment - Did you try to feed eclipse with a link such as http://download.eclipse.org/technology/m2e/milestones/1.1 I thing this that eclipse repos simply don't have any index page.
        Hide
        Andrus Adamchik added a comment -

        Actually I did on Saturday and it didn't work. Trying it again this morning, and I am getting a list of plugins. So seems to be some site problem. Anyways, now I seem to be ok.

        Show
        Andrus Adamchik added a comment - Actually I did on Saturday and it didn't work. Trying it again this morning, and I am getting a list of plugins. So seems to be some site problem. Anyways, now I seem to be ok.

          People

          • Assignee:
            Unassigned
            Reporter:
            Andrei Veprev
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development