Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Won't Fix
    • Affects Version/s: 1.1 [LEGACY]
    • Fix Version/s: None
    • Component/s: Modeler
    • Labels:
      None
    • Environment:
      W2K-SP4, J2SDK1.4.1_02

      Description

      CayenneModeler Info

      Version: 1.1M7_1

      Build Date: June 15 2004

      Exception:

      =================================

      org.objectstyle.cayenne.project.ProjectException: [v.1.1M7_1 June 15 2004] Unable to remove old master file : E:\workspace\cayenne-bos\cayennebos\WEB-INF\cayenne.xml

      at org.objectstyle.cayenne.project.ProjectFile.saveCommit(ProjectFile.java:221)

      at org.objectstyle.cayenne.project.Project.save(Project.java:382)

      at org.objectstyle.cayenne.modeler.action.SaveAction.saveAll(SaveAction.java:116)

      at org.objectstyle.cayenne.modeler.action.SaveAction.performAction(SaveAction.java:137)

      at org.objectstyle.cayenne.modeler.action.SaveAction.performAction(SaveAction.java:126)

      at org.objectstyle.cayenne.modeler.action.CayenneAction.actionPerformed(CayenneAction.java:184)

      at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:1764)

      at javax.swing.AbstractButton$ForwardActionEvents.actionPerformed(AbstractButton.java:1817)

      at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:419)

      at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:257)

      at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(BasicButtonListener.java:245)

      at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:227)

      at java.awt.Component.processMouseEvent(Component.java:5134)

      at java.awt.Component.processEvent(Component.java:4931)

      at java.awt.Container.processEvent(Container.java:1566)

      at java.awt.Component.dispatchEventImpl(Component.java:3639)

      at java.awt.Container.dispatchEventImpl(Container.java:1623)

      at java.awt.Component.dispatchEvent(Component.java:3480)

      at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:3450)

      at java.awt.LightweightDispatcher.processMouseEvent(Container.java:3165)

      at java.awt.LightweightDispatcher.dispatchEvent(Container.java:3095)

      at java.awt.Container.dispatchEventImpl(Container.java:1609)

      at java.awt.Window.dispatchEventImpl(Window.java:1590)

      at java.awt.Component.dispatchEvent(Component.java:3480)

      at java.awt.EventQueue.dispatchEvent(EventQueue.java:450)

      at java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:197)

      at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:150)

      at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:144)

      at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:136)

      at java.awt.EventDispatchThread.run(EventDispatchThread.java:99)

        Activity

        Andrus Adamchik added a comment -

        The underlying cause seems to be that E:\workspace\cayenne-bos\cayennebos\WEB-INF\cayenne.xml is locked by some other windows process... I guess fix on our part can be to display a friendly dialog instead of an exception stack, but you will still need to determine why the file can't be deleted.

        Andrus Adamchik added a comment -

        I am keeping this open, but as there is no existing fix (or rather clean way to reproduce it), I am changing the fix version from immediate to the next release... BTW, this problem has been mentioned to me by other developers privately, but also without any helpful details :-/

        Andrus Adamchik added a comment -

        CAY-233 is very similar to this one (so it was closed as a duplicate)...here is the stack from it:

        CayenneModeler Info

        Version: 1.1RC2

        Build Date: October 24 2004

        Exception:

        =================================

        java.io.IOException: Can't write to file: E:\relevance\src\corporatedb-rel\src\cayenne\cayenne.xml

        at org.objectstyle.cayenne.project.ProjectFile.checkWritePermissions(ProjectFile.java:285)

        at org.objectstyle.cayenne.project.ProjectFile.saveTemp(ProjectFile.java:174)

        at org.objectstyle.cayenne.project.Project.processSave(Project.java:448)

        at org.objectstyle.cayenne.project.Project.save(Project.java:375)

        at org.objectstyle.cayenne.modeler.action.SaveAsAction.saveAll(SaveAsAction.java:108)

        at org.objectstyle.cayenne.modeler.action.SaveAsAction.performAction(SaveAsAction.java:143)

        at org.objectstyle.cayenne.modeler.action.SaveAsAction.performAction(SaveAsAction.java:132)

        at org.objectstyle.cayenne.modeler.util.CayenneAction.actionPerformed(CayenneAction.java:188)

        at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:1786)

        at javax.swing.AbstractButton$ForwardActionEvents.actionPerformed(AbstractButton.java:1839)

        at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:420)

        at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:258)

        at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(BasicButtonListener.java:245)

        at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:231)

        at java.awt.Component.processMouseEvent(Component.java:5100)

        at java.awt.Component.processEvent(Component.java:4897)

        at java.awt.Container.processEvent(Container.java:1569)

        at java.awt.Component.dispatchEventImpl(Component.java:3615)

        at java.awt.Container.dispatchEventImpl(Container.java:1627)

        at java.awt.Component.dispatchEvent(Component.java:3477)

        at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:3483)

        at java.awt.LightweightDispatcher.processMouseEvent(Container.java:3198)

        at java.awt.LightweightDispatcher.dispatchEvent(Container.java:3128)

        at java.awt.Container.dispatchEventImpl(Container.java:1613)

        at java.awt.Window.dispatchEventImpl(Window.java:1606)

        at java.awt.Component.dispatchEvent(Component.java:3477)

        at java.awt.EventQueue.dispatchEvent(EventQueue.java:456)

        at java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:201)

        at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:151)

        at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:145)

        at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:137)

        at java.awt.EventDispatchThread.run(EventDispatchThread.java:100)

        Filip Balas added a comment -

        I do not know if this is helpful, but in my case it could be due to eclipse being open while I am editing using the modeler. I have the cayenne.xml as part of my tapestry project and eclipse may be opening the file occasionally to check for changes (just a theory). It could be the case that when I try to save while eclipse has a lock... this error occurs. If I try to save a few seconds later, it works fine.

        Perhaps a menu option with a number of retries and delay between retries should be added? Then after a few retries, a message saying that the file is locked as opposed to a dump could be displayed (as was mentioned).

        Andrus Adamchik added a comment -

        see the previous comment - we may need to add a few retries on windows

        Andrus Adamchik added a comment -

        Haven't seen any recent complaints about this.


          People

          • Assignee:
            Andrus Adamchik
            Reporter:
            Pat Klum
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development