Cayenne
  1. Cayenne
  2. CAY-1488

OutOfMemory when selecting "Remove Foreign Keys Mapped as Object Attributes"

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 3.0.1
    • Fix Version/s: 3.0.2, 3.1M1
    • Component/s: Modeler
    • Labels:
      None
    • Environment:
      MacOSX 10.6.3 / Java 1.6.0_17

      Description

      I just added a relationship in a DBEntity, and click on the "Sync dependant ObjEntities". I then get a panel with a checkbox:
      Remove Foreign Keys Mapped as Object Attributes

      When I leave the option selected, and press OK, the Modeler crashes immediately with OutOfMemoryError. When I deselect the option, it succeeds, and I have to remove the attribute by hand.

      I run the modeler via:
      mvn cayenne-modeler:run

      Increasing the memory didn't help:
      MAVEN_OPTS="-Xmx512m" mvn cayenne-modeler:run

      It still crashes, but not it takes 10sec to do so.

      This happened quite reliably on two different occasions with my model.

      1. CAY-1488.patch
        1 kB
        Andrei Veprev

        Activity

        Andrus Adamchik made changes -
        Status Open [ 1 ] Closed [ 6 ]
        Fix Version/s 3.0.2 [ 12315325 ]
        Fix Version/s 3.1M1 [ 12314299 ]
        Resolution Fixed [ 1 ]
        Andrus Adamchik added a comment -

        Andrei, the patch seems to be reverted, so I applied it with git apply -R to 3.0 and 3.1 branches. Thanks for the patch!

        Andrei Veprev made changes -
        Attachment CAY-1488.patch [ 12456276 ]
        Andrei Veprev added a comment -

        I was able to reproduce this bug with mapping from Tomas's mail.
        Here is patch.

        Andrus Adamchik made changes -
        Field Original Value New Value
        Assignee Andrus Adamchik [ andrus ]
        Andrus Adamchik added a comment -

        Looks very much like this: http://markmail.org/thread/g6yjhuqrseiayaae

        will need to investigate

        Marc Guenther created issue -

          People

          • Assignee:
            Andrus Adamchik
            Reporter:
            Marc Guenther
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development