Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Won't Fix
    • Affects Version/s: 3.0
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Environment:
      JDK 1.5, Maven 2.0.8

      Description

      Build fails after fresh checkout

      svn co http://svn.apache.org/repos/asf/cayenne/main/trunk/ cayenne

      C:\Users\Borut\Workarea\cayenne>mvn clean compile -U -Dmaven.test.skip=true -X
      + Error stacktraces are turned on.
      Maven version: 2.0.8
      Java version: 1.5.0_15
      OS name: "windows vista" version: "6.0" arch: "x86" Family: "windows"
      ...
      [INFO] [compiler:compile]
      [DEBUG] Using compiler 'javac'.
      [DEBUG] Source directories: [C:\Users\Borut\Workarea\cayenne\build-tools\maven-cayenne-doc-plugin\src\main\java]
      [DEBUG] Classpath: [C:\Users\Borut\Workarea\cayenne\build-tools\maven-cayenne-doc-plugin\target\classes
      C:\Users\Borut\.m2\repository\org\apache\maven\maven-archiver\2.2\maven-archiver-2.2.jar
      C:\Users\Borut\.m2\repository\org\apache\maven\maven-project\2.0\maven-project-2.0.jar
      C:\Users\Borut\.m2\repository\org\apache\maven\maven-profile\2.0\maven-profile-2.0.jar
      C:\Users\Borut\.m2\repository\org\apache\maven\maven-model\2.0\maven-model-2.0.jar
      C:\Users\Borut\.m2\repository\org\codehaus\plexus\plexus-utils\1.0.4\plexus-utils-1.0.4.jar
      C:\Users\Borut\.m2\repository\org\codehaus\plexus\plexus-container-default\1.0-alpha-8\plexus-container-default-1.0-alpha-8.jar
      C:\Users\Borut\.m2\repository\classworlds\classworlds\1.1-alpha-2\classworlds-1.1-alpha-2.jar
      C:\Users\Borut\.m2\repository\org\apache\maven\maven-artifact-manager\2.0\maven-artifact-manager-2.0.jar
      C:\Users\Borut\.m2\repository\org\apache\maven\maven-repository-metadata\2.0\maven-repository-metadata-2.0.jar
      C:\Users\Borut\.m2\repository\org\apache\maven\maven-artifact\2.0\maven-artifact-2.0.jar
      C:\Users\Borut\.m2\repository\org\apache\maven\wagon\wagon-provider-api\1.0-alpha-5\wagon-provider-api-1.0-alpha-5.jar
      C:\Users\Borut\.m2\repository\org\codehaus\plexus\plexus-archiver\1.0-alpha-7\plexus-archiver-1.0-alpha-7.jar
      C:\Users\Borut\.m2\repository\org\apache\maven\maven-plugin-api\2.0.4\maven-plugin-api-2.0.4.jar
      C:\Users\Borut\.m2\repository\axis\axis\1.4\axis-1.4.jar
      C:\Users\Borut\.m2\repository\axis\axis-jaxrpc\1.4\axis-jaxrpc-1.4.jar
      C:\Users\Borut\.m2\repository\axis\axis-saaj\1.4\axis-saaj-1.4.jar
      C:\Users\Borut\.m2\repository\velocity\velocity\1.4\velocity-1.4.jar
      C:\Users\Borut\.m2\repository\com\atlassian\confluence\confluence-soap\2.0\confluence-soap-2.0.jar]
      [DEBUG] Output directory: C:\Users\Borut\Workarea\cayenne\build-tools\maven-cayenne-doc-plugin\target\classes
      [DEBUG] Classpath:
      [DEBUG] C:\Users\Borut\Workarea\cayenne\build-tools\maven-cayenne-doc-plugin\target\classes
      [DEBUG] C:\Users\Borut\.m2\repository\org\apache\maven\maven-archiver\2.2\maven-archiver-2.2.jar
      [DEBUG] C:\Users\Borut\.m2\repository\org\apache\maven\maven-project\2.0\maven-project-2.0.jar
      [DEBUG] C:\Users\Borut\.m2\repository\org\apache\maven\maven-profile\2.0\maven-profile-2.0.jar
      [DEBUG] C:\Users\Borut\.m2\repository\org\apache\maven\maven-model\2.0\maven-model-2.0.jar
      [DEBUG] C:\Users\Borut\.m2\repository\org\codehaus\plexus\plexus-utils\1.0.4\plexus-utils-1.0.4.jar
      [DEBUG] C:\Users\Borut\.m2\repository\org\codehaus\plexus\plexus-container-default\1.0-alpha-8\plexus-container-default-1.0-alpha-8.jar
      [DEBUG] C:\Users\Borut\.m2\repository\classworlds\classworlds\1.1-alpha-2\classworlds-1.1-alpha-2.jar
      [DEBUG] C:\Users\Borut\.m2\repository\org\apache\maven\maven-artifact-manager\2.0\maven-artifact-manager-2.0.jar
      [DEBUG] C:\Users\Borut\.m2\repository\org\apache\maven\maven-repository-metadata\2.0\maven-repository-metadata-2.0.jar
      [DEBUG] C:\Users\Borut\.m2\repository\org\apache\maven\maven-artifact\2.0\maven-artifact-2.0.jar
      [DEBUG] C:\Users\Borut\.m2\repository\org\apache\maven\wagon\wagon-provider-api\1.0-alpha-5\wagon-provider-api-1.0-alpha-5.jar
      [DEBUG] C:\Users\Borut\.m2\repository\org\codehaus\plexus\plexus-archiver\1.0-alpha-7\plexus-archiver-1.0-alpha-7.jar
      [DEBUG] C:\Users\Borut\.m2\repository\org\apache\maven\maven-plugin-api\2.0.4\maven-plugin-api-2.0.4.jar
      [DEBUG] C:\Users\Borut\.m2\repository\axis\axis\1.4\axis-1.4.jar
      [DEBUG] C:\Users\Borut\.m2\repository\axis\axis-jaxrpc\1.4\axis-jaxrpc-1.4.jar
      [DEBUG] C:\Users\Borut\.m2\repository\axis\axis-saaj\1.4\axis-saaj-1.4.jar
      [DEBUG] C:\Users\Borut\.m2\repository\velocity\velocity\1.4\velocity-1.4.jar
      [DEBUG] C:\Users\Borut\.m2\repository\com\atlassian\confluence\confluence-soap\2.0\confluence-soap-2.0.jar
      [DEBUG] Source roots:
      [DEBUG] C:\Users\Borut\Workarea\cayenne\build-tools\maven-cayenne-doc-plugin\src\main\java
      [INFO] Compiling 6 source files to C:\Users\Borut\Workarea\cayenne\build-tools\maven-cayenne-doc-plugin\target\classes
      [INFO] ------------------------------------------------------------------------
      [INFO] Building Cayenne Build Tools Parent
      [INFO] task-segment: [clean, compile]
      [INFO] ------------------------------------------------------------------------
      [DEBUG] Configuring mojo 'org.apache.maven.plugins:maven-clean-plugin:2.2:clean' -->
      [DEBUG] (f) directory = C:\Users\Borut\Workarea\cayenne\build-tools\target
      [DEBUG] (f) failOnError = true
      [DEBUG] (f) followSymLinks = false
      [DEBUG] (f) outputDirectory = C:\Users\Borut\Workarea\cayenne\build-tools\target\classes
      [DEBUG] (f) project = MavenProject: org.apache.cayenne.parents:cayenne-build-tools:3.0-SNAPSHOT @ C:\Users\Borut\Workarea\cayenne\build-tools\pom.xml
      [DEBUG] (f) reportDirectory = C:\Users\Borut\Workarea\cayenne\build-tools\target\site
      [DEBUG] (f) skip = false
      [DEBUG] (f) testOutputDirectory = C:\Users\Borut\Workarea\cayenne\build-tools\target\test-classes
      [DEBUG] (f) verbose = false
      [DEBUG] – end configuration –
      [INFO] [clean:clean]
      [INFO] No goals needed for project - skipping
      [INFO] ------------------------------------------------------------------------
      [INFO] Building Cayenne License and Notice Bundle
      [INFO] task-segment: [clean, compile]
      [INFO] ------------------------------------------------------------------------
      [INFO] artifact org.apache.cayenne.build-tools:maven-cayenne-build-plugin: checking for updates from mergere
      [DEBUG] repository metadata for: 'artifact org.apache.cayenne.build-tools:maven-cayenne-build-plugin' could not be found on repository: mergere
      [INFO] artifact org.apache.cayenne.build-tools:maven-cayenne-build-plugin: checking for updates from central
      [DEBUG] repository metadata for: 'artifact org.apache.cayenne.build-tools:maven-cayenne-build-plugin' could not be found on repository: central
      [DEBUG] maven-cayenne-build-plugin: using locally installed snapshot
      [DEBUG] Artifact not found - using stub model: Unable to determine the latest version

      org.apache.cayenne.build-tools:maven-cayenne-build-plugin:pom:LATEST

      [DEBUG] Using defaults for missing POM org.apache.cayenne.build-tools:maven-cayenne-build-plugin:pom:LATEST
      [DEBUG] maven-cayenne-build-plugin: using locally installed snapshot
      [DEBUG] Artifact not found - using stub model: Unable to determine the release version

      org.apache.cayenne.build-tools:maven-cayenne-build-plugin:pom:RELEASE

      [DEBUG] Using defaults for missing POM org.apache.cayenne.build-tools:maven-cayenne-build-plugin:pom:RELEASE
      [INFO] ------------------------------------------------------------------------
      [ERROR] BUILD ERROR
      [INFO] ------------------------------------------------------------------------
      [INFO] The plugin 'org.apache.cayenne.build-tools:maven-cayenne-build-plugin' does not exist or no valid version could be found
      [INFO] ------------------------------------------------------------------------
      [DEBUG] Trace
      org.apache.maven.lifecycle.LifecycleExecutionException: The plugin 'org.apache.cayenne.build-tools:maven-cayenne-build-plugin' does not exist or no valid version could be found
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.verifyPlugin(DefaultLifecycleExecutor.java:1286)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.bindPluginToLifecycle(DefaultLifecycleExecutor.java:1221)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.constructLifecycleMappings(DefaultLifecycleExecutor.java:987)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoal(DefaultLifecycleExecutor.java:458)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoalAndHandleFailures(DefaultLifecycleExecutor.java:311)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeTaskSegments(DefaultLifecycleExecutor.java:278)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.execute(DefaultLifecycleExecutor.java:143)
      at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:333)
      at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:126)
      at org.apache.maven.cli.MavenCli.main(MavenCli.java:282)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:585)
      at org.codehaus.classworlds.Launcher.launchEnhanced(Launcher.java:315)
      at org.codehaus.classworlds.Launcher.launch(Launcher.java:255)
      at org.codehaus.classworlds.Launcher.mainWithExitCode(Launcher.java:430)
      at org.codehaus.classworlds.Launcher.main(Launcher.java:375)
      Caused by: org.apache.maven.plugin.version.PluginVersionNotFoundException: The plugin 'org.apache.cayenne.build-tools:maven-cayenne-build-plugin' does not exist or no valid version coul
      d be found
      at org.apache.maven.plugin.version.DefaultPluginVersionManager.resolvePluginVersion(DefaultPluginVersionManager.java:229)
      at org.apache.maven.plugin.version.DefaultPluginVersionManager.resolvePluginVersion(DefaultPluginVersionManager.java:91)
      at org.apache.maven.plugin.DefaultPluginManager.verifyPlugin(DefaultPluginManager.java:167)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.verifyPlugin(DefaultLifecycleExecutor.java:1257)
      ... 17 more
      [INFO] ------------------------------------------------------------------------
      [INFO] Total time: 15 seconds
      [INFO] Finished at: Tue Mar 11 17:49:12 CET 2008
      [INFO] Final Memory: 9M/21M
      [INFO] ------------------------------------------------------------------------

      Regards,
      Borut

        Activity

        Ari Maniatis made changes -
        Workflow jira [ 12456766 ] Cayenne workflow [ 12487262 ]
        Henri Yandell made changes -
        Project Import Sat Mar 21 00:51:04 PDT 2009 [ 1237621864637 ]
        Mike Kienenberger made changes -
        Field Original Value New Value
        Resolution Won't Fix [ 2 ]
        Status Open [ 1 ] Closed [ 6 ]
        Mike Kienenberger added a comment -

        Worked for me too.

        I don't know enough about maven to know if we can issue some kind of warning that "install" needs to be used instead of "compile," but since it's documented, I don't think we need to keep this open any longer.

        Borut Bolcina added a comment -

        I tried with mvn install and the build succedes, so consider this as non-issue. Maybe put a warning in the docs about not using mvn compile. Sorry for the false alarm.

        Mike Kienenberger added a comment -

        No, I just mindlessly copied what Borut had.
        I'll try

        mvn install clean compile -U -Dmaven.test.skip=true -X

        next, and then if it fails,

        mvn clean install -U -Dmaven.test.skip=true -X

        Andrus Adamchik added a comment -

        Mike, Borut, have you tried "mvn install" per developer guide (instead of "mvn compile")? This is required to load build plugin to the local repo among other things.

        Mike Kienenberger added a comment -

        For what it's worth, I get the same error using Maven 2.0.5 under Windows 2000 with Java 1.5.09

        Checked out:
        http://svn.apache.org/repos/asf/cayenne/main/trunk

        E:\workspace-cayenne\test>java -version
        java version "1.5.0_09"

        E:\workspace-cayenne\test>mvn clean compile -U -Dmaven.test.skip=true -X
        + Error stacktraces are turned on.
        Maven version: 2.0.5

        [...]

        [INFO] -------------------------------------------------------------------------

        [INFO] Building Cayenne Build Tools Parent
        [INFO] task-segment: [clean, compile]
        [INFO] -------------------------------------------------------------------------

        [DEBUG] Configuring mojo 'org.apache.maven.plugins:maven-clean-plugin:2.2:clean'
        -->
        [DEBUG] (f) directory = E:\workspace-cayenne\test\build-tools\target
        [DEBUG] (f) failOnError = true
        [DEBUG] (f) followSymLinks = false
        [DEBUG] (f) outputDirectory = E:\workspace-cayenne\test\build-tools\target\cla
        sses
        [DEBUG] (f) project = org.apache.maven.project.MavenProject@7564fa12
        [DEBUG] (f) reportDirectory = E:\workspace-cayenne\test\build-tools\target\sit
        e
        [DEBUG] (f) skip = false
        [DEBUG] (f) testOutputDirectory = E:\workspace-cayenne\test\build-tools\target
        \test-classes
        [DEBUG] (f) verbose = false
        [DEBUG] – end configuration –
        [INFO] [clean:clean]
        [INFO] No goals needed for project - skipping
        [INFO] -------------------------------------------------------------------------

        [INFO] Building Cayenne License and Notice Bundle
        [INFO] task-segment: [clean, compile]
        [INFO] -------------------------------------------------------------------------

        [INFO] artifact org.apache.cayenne.build-tools:maven-cayenne-build-plugin: check
        ing for updates from mergere
        [DEBUG] repository metadata for: 'artifact org.apache.cayenne.build-tools:maven-
        cayenne-build-plugin' could not be found on repository: mergere
        [INFO] artifact org.apache.cayenne.build-tools:maven-cayenne-build-plugin: check
        ing for updates from central
        [DEBUG] repository metadata for: 'artifact org.apache.cayenne.build-tools:maven-
        cayenne-build-plugin' could not be found on repository: central
        [DEBUG] maven-cayenne-build-plugin: using locally installed snapshot
        [DEBUG] Artifact not found - using stub model: Unable to determine the latest ve
        rsion

        org.apache.cayenne.build-tools:maven-cayenne-build-plugin:pom:LATEST

        [DEBUG] Using defaults for missing POM org.apache.cayenne.build-tools:maven-caye
        nne-build-plugin:pom:LATEST
        [DEBUG] maven-cayenne-build-plugin: using locally installed snapshot
        [DEBUG] Artifact not found - using stub model: Unable to determine the release v
        ersion

        org.apache.cayenne.build-tools:maven-cayenne-build-plugin:pom:RELEASE

        [DEBUG] Using defaults for missing POM org.apache.cayenne.build-tools:maven-caye
        nne-build-plugin:pom:RELEASE
        [INFO] ------------------------------------------------------------------------
        [ERROR] BUILD ERROR
        [INFO] ------------------------------------------------------------------------
        [INFO] The plugin 'org.apache.cayenne.build-tools:maven-cayenne-build-plugin' do
        es not exist or no valid version could be found
        [INFO] ------------------------------------------------------------------------
        [DEBUG] Trace
        org.apache.maven.lifecycle.LifecycleExecutionException: The plugin 'org.apache.c
        ayenne.build-tools:maven-cayenne-build-plugin' does not exist or no valid versio
        n could be found

        [...]

        Borut Bolcina created issue -

          People

          • Assignee:
            Andrus Adamchik
            Reporter:
            Borut Bolcina
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development