Uploaded image for project: 'Cassandra'
  1. Cassandra
  2. CASSANDRA-9451

Startup message response for unsupported protocol versions is incorrect

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Normal
    • Resolution: Fixed
    • Fix Version/s: 2.1.6, 2.2.0 rc1
    • Component/s: Legacy/CQL
    • Labels:
      None
    • Environment:

      OS X 10.9
      Cassandra 2.1.5

    • Severity:
      Normal
    • Impacts:
      Clients

      Description

      The response to a STARTUP request with protocol v4 on a C* 2.1 host is an error with an incorrect error code (0).

      Instead of the error code being "Protocol error" (0x000A) it has error code 0 and message (wrapped by netty):
      "io.netty.handler.codec.DecoderException: org.apache.cassandra.transport.ProtocolException: Invalid or unsupported protocol version: 4"

        Attachments

        1. 9451.txt
          5 kB
          Tom Hobbs

          Activity

            People

            • Assignee:
              stefania Stefania Alborghetti
              Reporter:
              jorgebg Jorge Bay
              Authors:
              Stefania Alborghetti
              Reviewers:
              Stefania Alborghetti
            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: