Uploaded image for project: 'Cassandra'
  1. Cassandra
  2. CASSANDRA-7988

2.1 broke cqlsh for IPv6

    XMLWordPrintableJSON

    Details

    • Type: New Feature
    • Status: Resolved
    • Priority: Normal
    • Resolution: Fixed
    • Fix Version/s: 2.1.1
    • Component/s: None
    • Labels:

      Description

      cqlsh in 2.1 switched to the cassandra-driver Python library, which only recently added IPv6 support. The version bundled with 2.1.0 does not include a sufficiently recent version, so cqlsh is unusable for those of us running IPv6 (us? me...?)

      The fix is to simply upgrade the bundled version of the Python cassandra-driver to at least version 2.1.1

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                thobbs Tom Hobbs
                Reporter:
                JshWright Josh Wright
                Authors:
                Tom Hobbs
                Reviewers:
                Philip Thompson
              • Votes:
                0 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: