Uploaded image for project: 'Cassandra'
  1. Cassandra
  2. CASSANDRA-5152

CQLSH prompt doesn't properly accept input characters on OSX

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Environment:

      OSX Mountain Lion

      Description

      In the terminal for OSX Mountain Lion, I execute 'cqlsh'. When I try to type the 't' letter, nothing appears on the screen. All other keys work, and no other shell application is affected in this manner. This is not an issue for Cassandra 1.1.6 - just started happening when I downloaded Cassandra 1.2.0

        Activity

        manishm@cloudera.com_impala_1546 Manish Maheshwari added a comment -

        Even with readline it didnt work for me - I had to use virtualenv

        virtualenv -p /usr/bin/python2.7 cqlsh_dir
        cd cqlsh_dir
        source ./bin/activate
        cqlsh
        Connected to Test Cluster at 127.0.0.1:9042.
        [cqlsh 5.0.1 | Cassandra 3.11.0 | CQL spec 3.4.4 | Native protocol v4]
        Use HELP for help.
        cqlsh> use test;
        cqlsh:test>
        
        brandon.kearby Brandon Kearby added a comment -

        I just ran into this issue. I solved it by installing readline for python.

        iamaleksey Aleksey Yeschenko added a comment -

        Mine is Python 2.7.2 from /usr/bin/python. I don't think that's Brew.

        You are right, it should be stock. Brew is 2.7.3.

        So, I can't reproduce with readline and you can't reproduce with libedit.

        We can either resolve it with "can't reproduce" or find someone else with stock python, just to be sure.

        iamaleksey Aleksey Yeschenko added a comment -

        Akshay Rao You don't need to install it (libedit). It's something you have with stock python with OS X.

        jbellis Jonathan Ellis added a comment -

        Mine is Python 2.7.2 from /usr/bin/python. I don't think that's Brew.

        akshayvrao Akshay Rao added a comment -

        Based on CASSANDRA-3597, do you recommend that I install the libedit module? I don't really remember installing it. For that matter, I don't quite remember installing python on my system.

        When issuing the command 'python --version', I get the following response: 'Python 2.7.2'. Is this okay? Should I install the lib edit module?

        iamaleksey Aleksey Yeschenko added a comment - - edited

        wfm as well, but we are both using python from brew.
        There is a chance that the issue is actually real with stock python (could be a consequence of CASSANDRA-3597). Although I don't remember any keys not working back then.

        jbellis Jonathan Ellis added a comment -

        t key WFM on OS X.


          People

          • Assignee:
            iamaleksey Aleksey Yeschenko
            Reporter:
            akshayvrao Akshay Rao
          • Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development