Cassandra
  1. Cassandra
  2. CASSANDRA-4977

Expose new SliceQueryFilter features through Thrift interface

    Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Invalid
    • Fix Version/s: None
    • Component/s: API
    • Labels:
      None

      Description

      SliceQueryFilter has some very useful new features like ability to specify a composite column prefix to group by and specify a limit of groups to return.

      This is very useful if for example I have a wide row with columns prefixed by timestamp and I want to retrieve the latest columns, but I don't know the column names. Say I have a row
      row -> (t1, c1), (t1, c2)... (t1, cn) ... (t0,c1) ... etc

      Query slice range (t1,) group by prefix (1) limit (1)

      As a more general question, is the Thrift interface going to be kept up-to-date with the feature changes or will it be left behind (a mistake IMO) ?

        Activity

        Mck SembWever added a comment -

        duplicate of CASSANDRA-2710 ?

        Cristian Opris added a comment -

        This was posted by me but apparently was logged with an anonymous account at the time


          People

          • Assignee:
            Unassigned
            Reporter:
            aaa
          • Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development