Uploaded image for project: 'Cassandra'
  1. Cassandra
  2. CASSANDRA-4498

Remove openjdk-6-jre Cassandra APT dependencies

    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Low
    • Resolution: Won't Fix
    • Fix Version/s: 1.2.0 beta 1
    • Component/s: None
    • Labels:

      Description

      As it is well known the recommended jre for Cassandra is sun java 1.6 but at this point that package no longer in the debian or ubuntu apt repos. In order to run Cassandra with the sun java 1.6 jre it must be installed manually with out the repos. Because of this when you install cassandra via the apache or datastax apt repos it must also install openjdk-6-jre even though sun java 1.6 jre is already installed.

      I would suggest that the java apt dependencies be removed from the Depends field in package configuration and move to either the Recommends or Suggests field so that way openjdk is not being downloaded when not necessary and possibly interfering with a be pre-installed jre

        Attachments

        1. apache_cassandra_Packages.diff
          0.6 kB
          Terrance Shepherd

          Activity

            People

            • Assignee:
              brandon.williams Brandon Williams
              Reporter:
              tscanausa Terrance Shepherd
              Authors:
              Brandon Williams
              Reviewers:
              paul cannon
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: