Cassandra
  1. Cassandra
  2. CASSANDRA-4307

isMarkedForDelete can return false if it is a few seconds in the future

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Fix Version/s: 1.1.2
    • Component/s: Core
    • Labels:
      None

      Description

      The patch in CASSANDRA-3716 causes some weird issues to arrise when server times don't exactly match up (and since the resolution is seconds, it is easy to be off by just enough to see it).

      I am seeing a case where during schema propagation .isMarkedForDelete() is checked, but the timestamp is a few seconds in the future because the schema was sent from a different node. The code then happily tries to interpret the value of the column as a String, but it is actually the Int encoded deletion time.

      Here is an example in the code that does this check and will do the wrong thing if the deletion timestamp is even just a few seconds in the future: https://github.com/apache/cassandra/blob/47f0cc5d38d272ec9f7d6179eb3ffa28c6f74107/src/java/org/apache/cassandra/cql3/statements/SelectStatement.java#L607-609

      To prove that this is a problem, here is a stack trace of a machine trying to interpret the "localDeletionTime" value of a DeletedColumn as UTF-8 because the .isMarkedForDeletion() check failed:

      https://gist.github.com/deb064d4377d206368d3

      1. 4307-test.txt
        2 kB
        Wade Simmons
      2. 4307.txt
        1.0 kB
        Sylvain Lebresne

        Activity

        Sylvain Lebresne added a comment -

        I believer you're right, good catch!
        Attaching patch to re-add the overwrite of isMarkedForDelete in DeletedColumn. We shouldn't have removed it since DeletedColumn should never ever be interpreted as live columns, even with lack of node synchronization (it's ok for expiring columns though).

        Jonathan Ellis added a comment -

        +1

        Wade Simmons added a comment -

        Test case to ensure no future regressions. Fails if 4307 patch is not applied.

        Sylvain Lebresne added a comment -

        Committed. I included the unit test, thanks Wade.


          People

          • Assignee:
            Sylvain Lebresne
            Reporter:
            Wade Simmons
            Reviewer:
            Jonathan Ellis
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development