Cassandra
  1. Cassandra
  2. CASSANDRA-4244

RangeSlice command with CL.One doesn't do RR

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Duplicate
    • Fix Version/s: None
    • Component/s: Core
    • Labels:
      None

      Description

      Looks like SP.getRangeSlice has the following code

      if (consistency_level == ConsistencyLevel.ONE && !liveEndpoints.isEmpty() && liveEndpoints.get(0).equals(FBUtilities.getBroadcastAddress()))

      We might want to change it to use LocalReadRunnable consistent with fetchRows.

        Activity

        Vijay created issue -
        Jonathan Ellis added a comment -

        duplicate of CASSANDRA-3687 and CASSANDRA-967

        Jonathan Ellis made changes -
        Field Original Value New Value
        Status Open [ 1 ] Resolved [ 5 ]
        Assignee Vijay [ vijay2win@yahoo.com ]
        Fix Version/s 1.1.1 [ 12319857 ]
        Resolution Duplicate [ 3 ]
        Gavin made changes -
        Workflow no-reopen-closed, patch-avail [ 12667390 ] patch-available, re-open possible [ 12749691 ]
        Gavin made changes -
        Workflow patch-available, re-open possible [ 12749691 ] reopen-resolved, no closed status, patch-avail, testing [ 12757183 ]

          People

          • Assignee:
            Unassigned
            Reporter:
            Vijay
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development