Cassandra
  1. Cassandra
  2. CASSANDRA-4048

SSTableLoader meets problem during the apply of the schema update

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Cannot Reproduce
    • Fix Version/s: None
    • Component/s: Tools
    • Labels:
      None

      Description

      SSTableLoader tries to apply the "drop column family" meta data update, and meets below problem. Seems like the column family
      is dropped multiple times?

      user@luzhou:/data/apache-cassandra-1.0.8$ bin/sstableloader -i hostA,hostB /tmp/out/store/
      Starting client (and waiting 30 seconds for gossip) ...
      java.lang.IllegalArgumentException: Unknown CF 1000
      at org.apache.cassandra.db.Table.getColumnFamilyStore(Table.java:167)
      at org.apache.cassandra.db.Table.getColumnFamilyStore(Table.java:160)
      at org.apache.cassandra.db.migration.DropColumnFamily.applyModels(DropColumnFamily.java:70)
      at org.apache.cassandra.db.migration.Migration.apply(Migration.java:156)
      at org.apache.cassandra.db.DefinitionsUpdateVerbHandler$1.runMayThrow(DefinitionsUpdateVerbHandler.java:73)
      at org.apache.cassandra.utils.WrappedRunnable.run(WrappedRunnable.java:30)
      at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
      at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
      at java.util.concurrent.FutureTask.run(FutureTask.java:166)
      at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
      at java.lang.Thread.run(Thread.java:679)
      ERROR 18:35:51,423 Error in ThreadPoolExecutor
      java.lang.IllegalArgumentException: Unknown CF 1000
      at org.apache.cassandra.db.Table.getColumnFamilyStore(Table.java:167)
      at org.apache.cassandra.db.Table.getColumnFamilyStore(Table.java:160)
      at org.apache.cassandra.db.migration.DropColumnFamily.applyModels(DropColumnFamily.java:70)
      at org.apache.cassandra.db.migration.Migration.apply(Migration.java:156)
      at org.apache.cassandra.db.DefinitionsUpdateVerbHandler$1.runMayThrow(DefinitionsUpdateVerbHandler.java:73)
      at org.apache.cassandra.utils.WrappedRunnable.run(WrappedRunnable.java:30)
      at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
      at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
      at java.util.concurrent.FutureTask.run(FutureTask.java:166)
      at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
      at java.lang.Thread.run(Thread.java:679)
      ERROR 18:35:51,595 Error in ThreadPoolExecutor
      java.lang.IllegalArgumentException: Unknown CF 1000
      at org.apache.cassandra.db.Table.getColumnFamilyStore(Table.java:167)
      at org.apache.cassandra.db.Table.getColumnFamilyStore(Table.java:160)
      at org.apache.cassandra.db.migration.DropColumnFamily.applyModels(DropColumnFamily.java:70)
      at org.apache.cassandra.db.migration.Migration.apply(Migration.java:156)
      at org.apache.cassandra.db.DefinitionsUpdateVerbHandler$1.runMayThrow(DefinitionsUpdateVerbHandler.java:73)
      at org.apache.cassandra.utils.WrappedRunnable.run(WrappedRunnable.java:30)
      at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
      at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
      at java.util.concurrent.FutureTask.run(FutureTask.java:166)
      at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
      at java.lang.Thread.run(Thread.java:679)

        Activity

        Zhu Han created issue -
        Zhu Han made changes -
        Field Original Value New Value
        Summary SSTableLoader should not apply the schema update SSTableLoader meets problem during the apply of the schema update
        Description SSTableLoader tries to apply the "drop column family" meta data update, and meets below problem. I do not think the node runs in client mode should apply these update.
        user@luzhou:/data/apache-cassandra-1.0.8$ bin/sstableloader -i hostA,hostB /tmp/out/store/
        Starting client (and waiting 30 seconds for gossip) ...
        ERROR 18:35:51,420 Error in ThreadPoolExecutor
        java.lang.IllegalArgumentException: Unknown CF 1000
        at org.apache.cassandra.db.Table.getColumnFamilyStore(Table.java:167)
        at org.apache.cassandra.db.Table.getColumnFamilyStore(Table.java:160)
        at org.apache.cassandra.db.migration.DropColumnFamily.applyModels(DropColumnFamily.java:70)
        at org.apache.cassandra.db.migration.Migration.apply(Migration.java:156)
        at org.apache.cassandra.db.DefinitionsUpdateVerbHandler$1.runMayThrow(DefinitionsUpdateVerbHandler.java:73)
        at org.apache.cassandra.utils.WrappedRunnable.run(WrappedRunnable.java:30)
        at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
        at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
        at java.util.concurrent.FutureTask.run(FutureTask.java:166)
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
        at java.lang.Thread.run(Thread.java:679)
        SSTableLoader tries to apply the "drop column family" meta data update, and meets below problem. Seems like the column family
        is dropped multiple times?

        user@luzhou:/data/apache-cassandra-1.0.8$ bin/sstableloader -i hostA,hostB /tmp/out/store/
        Starting client (and waiting 30 seconds for gossip) ...
        java.lang.IllegalArgumentException: Unknown CF 1000
        at org.apache.cassandra.db.Table.getColumnFamilyStore(Table.java:167)
        at org.apache.cassandra.db.Table.getColumnFamilyStore(Table.java:160)
        at org.apache.cassandra.db.migration.DropColumnFamily.applyModels(DropColumnFamily.java:70)
        at org.apache.cassandra.db.migration.Migration.apply(Migration.java:156)
        at org.apache.cassandra.db.DefinitionsUpdateVerbHandler$1.runMayThrow(DefinitionsUpdateVerbHandler.java:73)
        at org.apache.cassandra.utils.WrappedRunnable.run(WrappedRunnable.java:30)
        at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
        at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
        at java.util.concurrent.FutureTask.run(FutureTask.java:166)
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
        at java.lang.Thread.run(Thread.java:679)
        ERROR 18:35:51,423 Error in ThreadPoolExecutor
        java.lang.IllegalArgumentException: Unknown CF 1000
        at org.apache.cassandra.db.Table.getColumnFamilyStore(Table.java:167)
        at org.apache.cassandra.db.Table.getColumnFamilyStore(Table.java:160)
        at org.apache.cassandra.db.migration.DropColumnFamily.applyModels(DropColumnFamily.java:70)
        at org.apache.cassandra.db.migration.Migration.apply(Migration.java:156)
        at org.apache.cassandra.db.DefinitionsUpdateVerbHandler$1.runMayThrow(DefinitionsUpdateVerbHandler.java:73)
        at org.apache.cassandra.utils.WrappedRunnable.run(WrappedRunnable.java:30)
        at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
        at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
        at java.util.concurrent.FutureTask.run(FutureTask.java:166)
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
        at java.lang.Thread.run(Thread.java:679)
        ERROR 18:35:51,595 Error in ThreadPoolExecutor
        java.lang.IllegalArgumentException: Unknown CF 1000
        at org.apache.cassandra.db.Table.getColumnFamilyStore(Table.java:167)
        at org.apache.cassandra.db.Table.getColumnFamilyStore(Table.java:160)
        at org.apache.cassandra.db.migration.DropColumnFamily.applyModels(DropColumnFamily.java:70)
        at org.apache.cassandra.db.migration.Migration.apply(Migration.java:156)
        at org.apache.cassandra.db.DefinitionsUpdateVerbHandler$1.runMayThrow(DefinitionsUpdateVerbHandler.java:73)
        at org.apache.cassandra.utils.WrappedRunnable.run(WrappedRunnable.java:30)
        at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
        at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
        at java.util.concurrent.FutureTask.run(FutureTask.java:166)
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
        at java.lang.Thread.run(Thread.java:679)
        Jonathan Ellis added a comment -

        Unless you have a 1.0-specific fix I'm inclined to say "don't drop columnfamilies during bulk load," since we've already rewritten this for 1.1.

        Zhu Han added a comment -

        OK. This is on testing cluster. I tried "drop cfs" several times before the test. Whatever, it does not matter for the bulk load result...

        Gavin made changes -
        Workflow no-reopen-closed, patch-avail [ 12657896 ] patch-available, re-open possible [ 12749361 ]
        Gavin made changes -
        Workflow patch-available, re-open possible [ 12749361 ] reopen-resolved, no closed status, patch-avail, testing [ 12756961 ]
        Jonathan Ellis made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Cannot Reproduce [ 5 ]

          People

          • Assignee:
            Unassigned
            Reporter:
            Zhu Han
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development