So here's the deal: Other than running into
CASSANDRA-3797, there is the problem that we cannot have both the Coda Metrics and our own MBean:s publish under the same class name (StorageProxy in this case).
I considered various options, and decided to at least submit for consideration something that might be controversial: I have created an org.apache.cassandra.metrics package, containing a ClientRequestMetrics class which has these metrics. The idea is that if we are going to need to adjust naming conventions anyway, let's move to a naming convention which makes sense to the user/system administrator, rather than the implementor ("StorageProxy" means very little to most people who don't know the code, I would suspect).
It does create a split-world syndrome of "new style" vs. "old style" metrics though. I'd love input.
Attaching a patch (.jar binary is there on purpose).