Cassandra
  1. Cassandra
  2. CASSANDRA-3317

SStable corruption possible caused by Leveldb compaction

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Fix Version/s: None
    • Component/s: Core
    • Labels:
      None

      Description

      During stress testing of leveldb compaction i found that sometimes it create corrupted ssfile and
      cassandra starts with error. I am not sure what caused that error, but i cant reproduce it if i switch to standard
      compaction strategy.

      ERROR [SSTableBatchOpen:1] 2011-10-05 15:31:31,781 AbstractCassandraDaemon.java
      (line 133) Fatal exception in thread Thread[SSTableBatchOpen:1,5,main]
      java.lang.AssertionError
      at org.apache.cassandra.io.sstable.SSTableReader.open(SSTableReader.java
      :129)
      at org.apache.cassandra.io.sstable.SSTableReader$1.run(SSTableReader.jav
      a:196)
      at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:44
      1)
      at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
      at java.util.concurrent.FutureTask.run(FutureTask.java:138)
      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExec
      utor.java:886)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor
      .java:908)
      at java.lang.Thread.run(Thread.java:662)

        Activity

        Jonathan Ellis added a comment -

        I can't reproduce. Are you using the Cassandra stress tool or something else?

        Radim Kolar added a comment -

        this one is difficult to reproduce, probably timing dependant or
        something. i am using my own tool, it is doing batch writes and then
        mixed read/write workload.


          People

          • Assignee:
            Unassigned
            Reporter:
            Radim Kolar
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development