Uploaded image for project: 'Cassandra'
  1. Cassandra
  2. CASSANDRA-16696

pylib requirements.txt should demand six >=1.12.0 rather than 0.12.0

Agile BoardAttach filesAttach ScreenshotVotersWatch issueWatchersCreate sub-taskConvert to sub-taskMoveLinkCloneLabelsUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

Details

    • Operability
    • Low Hanging Fruit
    • All
    • None

    Description

      In 4.0 min six version is explicitly specified here

      https://github.com/apache/cassandra/blob/6c8ab5b6b41830ac0d0ee381a7669b06ffd5b43a/pylib/requirements.txt#L5

      but it is probably a typo: {{ six>=0.12.0 }}

      and should be >=1.12.0, version that ensures that "ensure_text" is present:

      see six PR: https://github.com/benjaminp/six/pull/204

      It can lead to import problems with pylib and in effect to problems with the cqlsh tests. 

      Proposed fix:

      1. request six>=1.12.0 in pylib requirements.txt on all C* branches
      2. request six>=1.12.0 in dtest requirements.txt 

       

      C* versions before 4.0 does not specify six version at all, which I suspect can be also improved.

       

      Attachments

        Activity

          This comment will be Viewable by All Users Viewable by All Users
          Cancel

          People

            tomasz.lasica Tomasz Lasica Assign to me
            tomasz.lasica Tomasz Lasica
            Tomasz Lasica
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Issue deployment