We have a bunch of inconsistent names and config patterns in the codebase, both from the yams and JVM properties. It would be nice to standardise the naming (such as otc_ vs internode_) as well as the provision of values with units - while maintaining perpetual backwards compatibility with the old parameter names, of course.
For temporal units, I would propose parsing strings with suffixes of:
For rate units, I would propose parsing any of the standard B/s, KiB/s, MiB/s, GiB/s, TiB/s.
Perhaps for avoiding ambiguity we could not accept bauds bs, Mbps or powers of 1000 such as KB/s, given these are regularly used for either their old or new definition e.g. KiB/s, or we could support them and simply log the value in bytes/s.