Uploaded image for project: 'Cassandra'
  1. Cassandra
  2. CASSANDRA-14774

Upgrade of snappy java and JNA

    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Open
    • Priority: Low
    • Resolution: Unresolved
    • Fix Version/s: 3.11.x
    • Component/s: Dependencies
    • Labels:
      None
    • Environment:

      Ubuntu, RHEL

      Description

      We are building Apache Cassandra for s390x. We have observed that current latest version 3.11.3 has snappy java 1.1.1.7 and JNA 4.2.2.

      However these versions doesn't have s390x support. s390x support is available in JNA 4.5.0 and snappy-java 1.1.2.6

      Is it possible to upgrade JNA from 4.2.2. to 4.5.0?
      Also the snappy from 1.1.1.7 to 1.1.2.6?

      Please let us know if you need more info.

       

       

       

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              Nayana Nayana Thorat
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated: