Uploaded image for project: 'Cassandra'
  1. Cassandra
  2. CASSANDRA-12996

update slf4j dependency to 1.7.21

    XMLWordPrintableJSON

Details

    • Improvement
    • Status: Resolved
    • Normal
    • Resolution: Fixed
    • 4.0-alpha1, 4.0
    • Dependencies
    • None

    Description

      Cassandra 3.11.0 is about to be included in Fedora. There are some tweaks to the sources we need to do in order to successfully build it. Cassandra depends on slf4j 1.7.7, but In Fedora we have the latest upstream version 1.7.21 It was released some time ago on April 6 2016. I attached a patch updating Cassandra sources to depend on the newer slf4j sources. The only actual change is the number of parameters accepted by SubstituteLogger class. Please consider updating.

      Attachments

        1. slf4j-api-1.7.25.jar.asc
          0.4 kB
          Stefan Podkowinski
        2. log4j-over-slf4j-1.7.25.jar.asc
          0.4 kB
          Stefan Podkowinski
        3. jcl-over-slf4j-1.7.25.jar.asc
          0.4 kB
          Stefan Podkowinski
        4. cassandra-3.11.0-slf4j.patch
          0.9 kB
          Tomas Repik

        Issue Links

          Activity

            People

              spod Stefan Podkowinski
              trepik Tomas Repik
              Stefan Podkowinski
              Robert Stupp
              Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: