Uploaded image for project: 'Cassandra'
  1. Cassandra
  2. CASSANDRA-10561

Add a check to cqlsh to require Python-2.7 for version >= 2.2

Agile BoardAttach filesAttach ScreenshotBulk Copy AttachmentsBulk Move AttachmentsVotersWatch issueWatchersCreate sub-taskConvert to sub-taskMoveLinkCloneLabelsUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

Details

    • Bug
    • Status: Resolved
    • Low
    • Resolution: Fixed
    • 2.2.4, 3.0.0
    • Legacy/CQL
    • None
    • Low

    Description

      Not everybody is reading the README file. Up to now cqlsh was still working with python 2.6 by consequence user complains when we use some python-2.7 features.
      We should still allow python-2.6 with 2.1 but enforce the use of python 2.7 in 2.2+.

      Attachments

        1. 10561-2.2-V2.txt
          0.6 kB
          Benjamin Lerer
        2. 10561-2.2.txt
          0.6 kB
          Benjamin Lerer

        Activity

          This comment will be Viewable by All Users Viewable by All Users
          Cancel

          People

            blerer Benjamin Lerer Assign to me
            blerer Benjamin Lerer
            Benjamin Lerer
            Stefania Alborghetti
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Slack

                Issue deployment