Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Won't Fix
    • Fix Version/s: 0.7.1
    • Component/s: Core
    • Labels:
      None
    • Environment:

      debian lenny amd64 OpenJDK 64-Bit Server VM (build 1.6.0_0-b11, mixed mode)

      Description

      There appears to be a GC issue due to memory pressure in the 0.6 branch. You can see this by starting the server and performing many inserts. Quickly the jvm will consume most of its heap, and pauses for stop-the-world GC will begin. With verbose GC turned on, this can be observed as follows:

      [GC [ParNew (promotion failed): 79703K->79703K(84544K), 0.0622980 secs][CMS[CMS-concurrent-mark: 3.678/5.031 secs] [Times: user=10.35 sys=4.22, real=5.03 secs]
      (concurrent mode failure): 944529K->492222K(963392K), 2.8264480 secs] 990745K->492222K(1047936K), 2.8890500 secs] [Times: user=2.90 sys=0.04, real=2.90 secs]

      After enough inserts (around 75-100 million) the server will GC storm and then OOM.

      jbellis and I narrowed this down to patch 0001 in CASSANDRA-724. Switching LBQ with ABQ made no difference, however using batch mode instead of periodic for the commitlog does prevent the issue from occurring. The attached screenshot shows the heap usage in jconsole first when the issue is exhibiting, a restart, and then the same amount of inserts when it does not.

      1. 724-0001.png
        65 kB
        Brandon Williams
      2. 1014-table.diff
        0.9 kB
        Jonathan Ellis
      3. 1014-commitlog-v2.tar.gz
        18 kB
        Jonathan Ellis
      4. 1014-2Gheap.png
        90 kB
        Brandon Williams
      5. gc2.png
        52 kB
        Lu Ming

        Issue Links

          Activity

          Gavin made changes -
          Workflow patch-available, re-open possible [ 12752210 ] reopen-resolved, no closed status, patch-avail, testing [ 12758191 ]
          Gavin made changes -
          Workflow no-reopen-closed, patch-avail [ 12509117 ] patch-available, re-open possible [ 12752210 ]
          Jonathan Ellis made changes -
          Status Open [ 1 ] Resolved [ 5 ]
          Resolution Won't Fix [ 2 ]
          Jonathan Ellis added a comment -

          There are several problems that can be conflated here:

          • the more writes you do, the larger your memory usage will be for bloom filters and index samples. This is normal and part of the design
          • there have been JVM-level memory leaks. upgrade to the most recent Sun JDK.
          • Cassandra outstrips the JVM's GC capacity. We can tackle this by reducing the amount of garbage we generate, e.g. with CASSANDRA-1814 and CASSANDRA-1714
          Jonathan Ellis made changes -
          Fix Version/s 0.7.1 [ 12315199 ]
          Fix Version/s 0.7.0 [ 12315212 ]
          Peter Schuller added a comment -

          ... and correcting myself I realized that it is unlikely that fragmentation overhead gets reported as "used", so my second point is probably bogus.

          Peter Schuller added a comment -

          I have not read anything about this other than what is in this ticket, and the beginnings of this is old, so this may be moot, but a couple of things:

          • The first graph attached (1014-2Gheap.png) looks to me like the JVM is only doing young generation collections and is simply not ever doing a concurrent mark/sweep phase. That would be a VM bug (or broken VM options).
          • Is the 60 mb vs. 368 mb the difference between a CMS full collection and a stop-the-world full collection? I.e., it was 368 right after a full CMS sweep? It need not necessarily indicate a VM bug; consider that CMS's old gen is maintained in a non-compacting/copying fashion and that the CMS old gen is thus susceptible to fragmentation overhead. A full stop-the-world GC also applies, AFAIK, that it does a compacting GC. A factor of 6.1 seems like a lot though, but I don't know about how the CMS free space management works. If the 6.1 is explained by fragmentation, my initial guess would be that large allocations are the triggering factor.
          Jonathan Ellis added a comment -

          slicing 10k columns at once inherently uses a lot of memory and is probably not related to this issue.

          Lee Cheng Wei added a comment -

          Just reproduced this bug minutes ago, we've inserted 10,000,000 column into a single row for benchmarks, we spent a whole weekend for the inserts, and tried to slice query them out today, the server was fine in beginning queries, and the becoming worse after some large range slice queries like 10,000 columns in the same time.

          We are using nightly build at 2010-08-12_13-11-16.

          It looks fine in the weekend according to the system.log, things getting worse after the query.

          Jonathan Ellis made changes -
          Assignee Jonathan Ellis [ jbellis ]
          Fix Version/s 0.7.0 [ 12315212 ]
          Fix Version/s 0.6.4 [ 12315173 ]
          Torsten Curdt added a comment -

          Hey Brandon,

          maybe it does happen after a much longer time. All I can say is that through thrift we hit the wall at around 100M inserts.
          Through the StorageProxy we inserted around 500M much faster and without any issues at all.

          Daniel Kluesing added a comment -

          Just another observation: I have a big nightly import - several hundred million records that come in through the thrift interface - which caused this behavior. For this particular CF, I don't need the level of assurance the commit log provides, we ended up making the commit log configurable on a per-column family basis (with a EnableCommitLog attribute on the CF) . Inserts to that particular column family just skip the commit log. This eliminated the gc thrashing during those imports. Been doing the nightly import for well over a month, no issues.

          I just needed the import to work, and killing the commitlog for CFs that take heavy inserts made the problem go away. it works so I never dug any deeper.

          Brandon Williams added a comment -

          Torsten,

          How many rows did you go through with StorageProxy? I would expect to get further without thrift's garbage overhead, but given enough time, the issue would still occur.

          Torsten Curdt added a comment -

          Good summary.

          A few more things:

          • using the most recent (watch the patch levels!) java6 jvm is crucial and improved the situation (not solved it though)
          • inserting row mutation directly through the StorageProxy does NOT seem to cause this behavior. (we have seen much higher throughput and the GC behavior was OK)
          Brandon Williams added a comment -

          To summarize the current status since there's a lot of noise in this ticket:

          With a 1GB heap and constant inserts, the server will begin to GC storm around the 100M row mark, and eventually OOM. Increasing the heap size doesn't help, it just takes longer to reproduce. The old gen continues to slowly grow until it's full and can't keep up. If you stop the inserts and force a STW GC, memory usage returns to normal. If you analyze a heap dump in MAT, it's not very helpful, most of the heap will be used by 'other' and tracing the GC roots of those objects is fruitless. Using other collectors doesn't improve the situation, ParOld and G1 both produce the same behavior. The GC options committed earlier in this ticket helped, but did not solve the situation. Using either batch or periodic mode doesn't matter, though batch takes longer to exhibit the issue.

          Jonathan Ellis added a comment -

          I thought the default CMSInitiatingOccupancyFraction is around 70, so that would make it later

          but the real problem in this issue is that CMS seems to "leak" memory under a write workload, but STW collection does collect it

          B. Todd Burruss added a comment -

          i had some issues like this until i added the following :

          -XX:CMSInitiatingOccupancyFraction=88

          which causes the parallel GC to kick in sooner, if i understand correctly. in my case, this is good enough so i do not have periodic freezes because of full on GC

          Brandon Williams added a comment -

          Tried that, and also tried the experimental G1 collector. Neither help. I had a hunch maybe disabling mmap would help, but unfortunately that didn't pan out either.

          Jonathan Ellis added a comment -

          Can you test

          -XX:+UseParallelGC -XX:+UseParallelOldGC

          instead of

          -XX:+UseConcMarkSweepGC \
          -XX:+CMSParallelRemarkEnabled \

          ?

          pause time for the former is expected to suck but it should demonstrate whether we are running into a CMS bug.

          Jonathan Ellis added a comment -

          This is sounding more and more to me like a bug in CMS, since stop-the-world collections make it go away. (We're not allocating that much during a sweep!)

          Jonathan Ellis made changes -
          Fix Version/s 0.6.4 [ 12315173 ]
          Fix Version/s 0.6.3 [ 12315056 ]
          Lu Ming made changes -
          Attachment gc2.png [ 12448014 ]
          Lu Ming added a comment - - edited

          GC Storm of my Cassandra Node

          Our service pause for several seconds every one or two minute's interval.

          Brandon Williams added a comment -

          I did some more thorough testing with batch vs periodic for the commitlog, and the issue still shows up with batch, it just takes longer to manifest due to the slower write speed.

          Jonathan Ellis added a comment - - edited

          Jacob Kessler explains:

          Without the ExplicitGCInvokesConcurrent option, a manually-invoked GC (Anything that calls System.gc(), including the mbean) will invoke a full stop-the-world collection, which has a few different properties in terms of the garbage that it can safely collect than the CMS Cassandra usually uses, i.e. all of it, rather than not collecting things that weren't garbage at the beginning of the sweep.

          Off-hand, though, I'd say that those graphs make it look very much like you have a memory leak. I'd wonder if you end up holding stuff for too long in the commitlog (I don't know what that is, but changing what you do with it seems to change you memory behavior =), possibly waiting for a lull in inserts to write it or something like that? I've definitely seen cases where the pause of a full GC causes things in the program to time out and become garbage, which then at least temporarily solves the problem.

          Torsten Curdt added a comment -

          As discussed on IRC I've force a GC which indeed helped.

          [code]
          $>get -b java.lang:type=Memory HeapMemoryUsage
          #mbean = java.lang:type=Memory:
          HeapMemoryUsage =

          { committed = 919076864; init = 268435456; max = 1072758784; used = 383.973.136; }

          ;

          $>run -b java.lang:type=Memory gc
          #calling operation gc of mbean java.lang:type=Memory

          $>get -b java.lang:type=Memory HeapMemoryUsage
          #mbean = java.lang:type=Memory:
          HeapMemoryUsage =

          { committed = 919076864; init = 268435456; max = 1072758784; used = 60.719.096; }

          ;
          [code]

          So it looks like we were hitting this with 0.6.2 as well. IIUC this should be fixed in 0.6.3?

          What's interesting is that writing through the StorageProxy our cluster is behaving much better. Even without a fix.

          Torsten Curdt made changes -
          Link This issue is related to CASSANDRA-1177 [ CASSANDRA-1177 ]
          Jonathan Ellis added a comment -

          committed the best GC options we have so far (thanks to Jacob Kessler) in r947743. still needs some work so leaving ticket open.

          Eric Evans made changes -
          Fix Version/s 0.6.3 [ 12315056 ]
          Fix Version/s 0.6.2 [ 12314931 ]
          Jonathan Ellis made changes -
          Status Patch Available [ 10002 ] Open [ 1 ]
          Jonathan Ellis added a comment -

          From IRC: "gdusbabek: +1 on #1014. (jira appears to be taking a nap)."

          Committed.

          Gary Dusbabek added a comment -

          +1

          Jonathan Ellis added a comment -

          we've moved the wait into the add() call, rather than an if statement afterwards

          Gary Dusbabek added a comment -

          It seems to me that we're decreasing write durability in batch mode by not waiting for the CL to record the mutation. Is that a good thing? If so, Table.waitForCommitLog can be removed completely.

          Jonathan Ellis made changes -
          Attachment 1014-commitlog.tar.gz [ 12442589 ]
          Jonathan Ellis made changes -
          Attachment 1014.txt [ 12442585 ]
          Brandon Williams made changes -
          Attachment 1014-2Gheap.png [ 12442749 ]
          Brandon Williams added a comment -

          I thought perhaps the heap just needed more breathing room, but here is a screenshot of jconsole on a 2G heap at around 300M inserts... same effect.

          Brandon Williams added a comment -

          Confirmed, 100M inserts works with this patch, though CMS still had tons of concurrent mode failures. 18 minutes of GC time on ParNew, 1 hour 26 minutes on CMS.

          Jonathan Ellis made changes -
          Status Open [ 1 ] Patch Available [ 10002 ]
          Assignee Jonathan Ellis [ jbellis ]
          Jonathan Ellis added a comment -

          Brandon reports that "I don't think patched cassandra is going to OOM on the 100M inserts, at 77M now and not GC storming, which definitely would happen w/o patches and compaction running like it is," however there is still significantly more GC activity in Periodic mode than Batch.

          Jonathan Ellis made changes -
          Attachment 1014-commitlog-v2.tar.gz [ 12442617 ]
          Jonathan Ellis made changes -
          Attachment 1014-commitlog.tar.gz [ 12442589 ]
          Jonathan Ellis made changes -
          Attachment 1014-table.diff [ 12442588 ]
          Jonathan Ellis added a comment -

          svn is generating a patch that doesn't work, so splitting it up into the changes to Table as a diff, and the changes to commitlog/ package as a tar

          Jonathan Ellis made changes -
          Fix Version/s 0.6.2 [ 12314931 ]
          Affects Version/s 0.6 [ 12314361 ]
          Affects Version/s 0.6.1 [ 12314867 ]
          Component/s Core [ 12312978 ]
          Jonathan Ellis made changes -
          Attachment 1014.txt [ 12442585 ]
          Jonathan Ellis added a comment -

          patch to split CLES into PeriodicCLES and BatchCLES, and adds an add(LogRecordAdder) method that will handle blocking if necessary.

          BCLES works basically the way it does already, which does not have the garbage problem.

          PCLES attempts to let the garbage get collected earlier by not returning it up two levels to Table. (It also generates slightly less garbage by using FutureTask directly instead of CheaterFutureTask.)

          Brandon Williams made changes -
          Description There appears to be a GC issue due to memory pressure in the 0.6 branch. You can see this by starting the server and performing many inserts. Quickly the jvm will consume most of its heap, and pauses for stop-the-world GC will begin. With verbose GC turned on, this can be observed as follows:

          [GC [ParNew (promotion failed): 79703K->79703K(84544K), 0.0622980 secs][CMS[CMS-concurrent-mark: 3.678/5.031 secs] [Times: user=10.35 sys=4.22, real=5.03 secs]
           (concurrent mode failure): 944529K->492222K(963392K), 2.8264480 secs] 990745K->492222K(1047936K), 2.8890500 secs] [Times: user=2.90 sys=0.04, real=2.90 secs]

          After enough inserts (around 75-100 million) the server will GC storm and then OOM.

          jbellis and I narrowed this down to patch 0001 in CASSANDRA-724. Switching LBQ with ABQ made no difference, however using batch mode instead of periodic for the commitlog does prevent the issue from occurring. The attached screenshot show the heap usage in jconsole first when the issue is exhibiting, a restart, and then the same amount of inserts when it does not.
          There appears to be a GC issue due to memory pressure in the 0.6 branch. You can see this by starting the server and performing many inserts. Quickly the jvm will consume most of its heap, and pauses for stop-the-world GC will begin. With verbose GC turned on, this can be observed as follows:

          [GC [ParNew (promotion failed): 79703K->79703K(84544K), 0.0622980 secs][CMS[CMS-concurrent-mark: 3.678/5.031 secs] [Times: user=10.35 sys=4.22, real=5.03 secs]
           (concurrent mode failure): 944529K->492222K(963392K), 2.8264480 secs] 990745K->492222K(1047936K), 2.8890500 secs] [Times: user=2.90 sys=0.04, real=2.90 secs]

          After enough inserts (around 75-100 million) the server will GC storm and then OOM.

          jbellis and I narrowed this down to patch 0001 in CASSANDRA-724. Switching LBQ with ABQ made no difference, however using batch mode instead of periodic for the commitlog does prevent the issue from occurring. The attached screenshot shows the heap usage in jconsole first when the issue is exhibiting, a restart, and then the same amount of inserts when it does not.
          Brandon Williams made changes -
          Field Original Value New Value
          Attachment 724-0001.png [ 12442575 ]
          Brandon Williams created issue -

            People

            • Assignee:
              Unassigned
              Reporter:
              Brandon Williams
            • Votes:
              2 Vote for this issue
              Watchers:
              19 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development