Uploaded image for project: 'Camel'
  1. Camel
  2. CAMEL-9751

Add support for security requirements to swagger java component

    XMLWordPrintableJSON

    Details

    • Type: New Feature
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.22.0
    • Component/s: camel-swagger
    • Labels:
      None
    • Estimated Complexity:
      Unknown

      Description

      Swagger Java component does not currently allow security requirements to be specified. Would be useful to be able to do so.
      But as security is usually applied at the container level its not clear what the best approach would be.

        Attachments

          Activity

            People

            • Assignee:
              davsclaus Claus Ibsen
              Reporter:
              tdudgeon Tim Dudgeon
            • Votes:
              1 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: