Uploaded image for project: 'Camel'
  1. Camel
  2. CAMEL-9402

Upgrade Spring Dependency to 4.1.9.RELEASE or later

    Details

    • Type: Task
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.16.1
    • Fix Version/s: 2.16.2, 2.17.0
    • Component/s: None
    • Labels:
      None
    • Estimated Complexity:
      Unknown

      Description

      Camel 2.16.1 has dependencies on spring 4.1.8.RELEASE

      This is causing Sonatype Nexus Pro reports to identify a level 9 threat (See "foxglove" link) against artifact spring-core used in Camel.

      Upgrade dependency to 4.2.3.RELEASE (see linked SPR issue).

        Attachments

          Activity

            People

            • Assignee:
              davsclaus Claus Ibsen
              Reporter:
              marks Mark Symons
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: