Uploaded image for project: 'Camel'
  1. Camel
  2. CAMEL-9099

[camel-script] wrong detection of script engine factories

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.15.3
    • Fix Version/s: 2.16.0, 2.15.4
    • Component/s: camel-script
    • Labels:
      None
    • Estimated Complexity:
      Unknown

      Description

      java.lang.ClassNotFoundException: # Licensed to the Apache Software Foundation (ASF) under one or more not found by groovy-all [228]
      	at org.apache.felix.framework.BundleWiringImpl.findClassOrResourceByDelegation(BundleWiringImpl.java:1556)[org.apache.felix.framework-4.4.1.jar:]
      	at org.apache.felix.framework.BundleWiringImpl.access$400(BundleWiringImpl.java:77)[org.apache.felix.framework-4.4.1.jar:]
      	at org.apache.felix.framework.BundleWiringImpl$BundleClassLoader.loadClass(BundleWiringImpl.java:1993)[org.apache.felix.framework-4.4.1.jar:]
      	at java.lang.ClassLoader.loadClass(ClassLoader.java:357)[:1.8.0_51]
      	at org.apache.felix.framework.Felix.loadBundleClass(Felix.java:1853)[org.apache.felix.framework-4.4.1.jar:]
      	at org.apache.felix.framework.BundleImpl.loadClass(BundleImpl.java:958)[org.apache.felix.framework-4.4.1.jar:]
      	at org.apache.camel.script.osgi.Activator$BundleScriptEngineResolver.getFactory(Activator.java:229)[230:org.apache.camel.camel-script:2.15.1]
      	at org.apache.camel.script.osgi.Activator$BundleScriptEngineResolver.getScriptNames(Activator.java:210)[230:org.apache.camel.camel-script:2.15.1]
      	at org.apache.camel.script.osgi.Activator$BundleScriptEngineResolver.access$000(Activator.java:191)[230:org.apache.camel.camel-script:2.15.1]
      	at org.apache.camel.script.osgi.Activator.getAvailableScriptNames(Activator.java:118)[230:org.apache.camel.camel-script:2.15.1]
      	at org.apache.camel.script.osgi.Activator.updateAvailableScriptLanguages(Activator.java:138)[230:org.apache.camel.camel-script:2.15.1]
      	at org.apache.camel.script.osgi.Activator.removedBundle(Activator.java:107)[230:org.apache.camel.camel-script:2.15.1]
      	at org.apache.camel.impl.osgi.tracker.BundleTracker$Tracked.customizerRemoved(BundleTracker.java:455)[176:org.apache.camel.camel-core:2.15.1]
      	at org.apache.camel.impl.osgi.tracker.AbstractTracked.untrack(AbstractTracked.java:346)[176:org.apache.camel.camel-core:2.15.1]
      	at org.apache.camel.impl.osgi.tracker.BundleTracker$Tracked.bundleChanged(BundleTracker.java:413)[176:org.apache.camel.camel-core:2.15.1]
      	at org.apache.felix.framework.util.EventDispatcher.invokeBundleListenerCallback(EventDispatcher.java:869)[org.apache.felix.framework-4.4.1.jar:]
      	at org.apache.felix.framework.util.EventDispatcher.fireEventImmediately(EventDispatcher.java:790)[org.apache.felix.framework-4.4.1.jar:]
      	at org.apache.felix.framework.util.EventDispatcher.fireBundleEvent(EventDispatcher.java:515)[org.apache.felix.framework-4.4.1.jar:]
      	at org.apache.felix.framework.Felix.fireBundleEvent(Felix.java:4429)[org.apache.felix.framework-4.4.1.jar:]
      	at org.apache.felix.framework.Felix.stopBundle(Felix.java:2528)[org.apache.felix.framework-4.4.1.jar:]
      	at org.apache.felix.framework.Felix$RefreshHelper.stop(Felix.java:4859)[org.apache.felix.framework-4.4.1.jar:]
      	at org.apache.felix.framework.Felix.refreshPackages(Felix.java:4130)[org.apache.felix.framework-4.4.1.jar:]
      	at org.apache.felix.framework.FrameworkWiringImpl.run(FrameworkWiringImpl.java:178)[org.apache.felix.framework-4.4.1.jar:]
      	at java.lang.Thread.run(Thread.java:745)[:1.8.0_51]
      

        Attachments

          Activity

            People

            • Assignee:
              gzres Grzegorz Grzybek
              Reporter:
              gzres Grzegorz Grzybek
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: