Uploaded image for project: 'Camel'
  1. Camel
  2. CAMEL-7817

Feature validation of camel-spring-redis is failing

    XMLWordPrintableJSON

Details

    • Task
    • Status: Resolved
    • Major
    • Resolution: Later
    • 2.15.0
    • None
    • camel-spring-redis, osgi
    • None
    • Unknown

    Description

      The feature validation of camel-spring-redis is failing:

      cmueller$ mvn install -Pvalidate
      ...
      [WARNING] Failed to validate feature camel-spring-redis
      [WARNING] No export found to match org.springframework.dao;version="[3.2.9, 4.0.5)" (imported by mvn:org.springframework.data/spring-data-redis/1.3.4.RELEASE)
      [WARNING] No export found to match org.springframework.transaction.support;version="[3.2.9, 4.0.5)" (imported by mvn:org.springframework.data/spring-data-redis/1.3.4.RELEASE)
      [WARNING] No export found to match org.springframework.context;version="[3.2.9, 4.0.5)" (imported by mvn:org.springframework.data/spring-data-redis/1.3.4.RELEASE)
      [WARNING] No export found to match org.springframework.core.serializer.support;version="[3.2.9, 4.0.5)" (imported by mvn:org.springframework.data/spring-data-redis/1.3.4.RELEASE)
      [WARNING] No export found to match org.springframework.util;version="[3.2.9, 4.0.5)" (imported by mvn:org.springframework.data/spring-data-redis/1.3.4.RELEASE)
      [WARNING] No export found to match org.springframework.cache.support;version="[3.2.9, 4.0.5)" (imported by mvn:org.springframework.data/spring-data-redis/1.3.4.RELEASE)
      [WARNING] No export found to match org.springframework.core.io.support;version="[3.2.9, 4.0.5)" (imported by mvn:org.springframework.data/spring-data-redis/1.3.4.RELEASE)
      [WARNING] No export found to match org.springframework.beans;version="[3.2.9, 4.0.5)" (imported by mvn:org.springframework.data/spring-data-redis/1.3.4.RELEASE)
      [WARNING] No export found to match org.springframework.cache.transaction;version="[3.2.9, 4.0.5)" (imported by mvn:org.springframework.data/spring-data-redis/1.3.4.RELEASE)
      [WARNING] No export found to match org.springframework.beans.factory.support;version="[3.2.9, 4.0.5)" (imported by mvn:org.springframework.data/spring-data-redis/1.3.4.RELEASE)
      [WARNING] No export found to match org.springframework.core.io;version="[3.2.9, 4.0.5)" (imported by mvn:org.springframework.data/spring-data-redis/1.3.4.RELEASE)
      [WARNING] No export found to match org.springframework.core.convert.support;version="[3.2.9, 4.0.5)" (imported by mvn:org.springframework.data/spring-data-redis/1.3.4.RELEASE)
      [WARNING] No export found to match org.springframework.aop.framework;version="[3.2.9, 4.0.5)" (imported by mvn:org.springframework.data/spring-data-redis/1.3.4.RELEASE)
      [WARNING] No export found to match org.springframework.core.convert.converter;version="[3.2.9, 4.0.5)" (imported by mvn:org.springframework.data/spring-data-redis/1.3.4.RELEASE)
      [WARNING] No export found to match org.springframework.cglib.proxy;version="[3.2.9, 4.0.5)" (imported by mvn:org.springframework.data/spring-data-redis/1.3.4.RELEASE)
      [WARNING] No export found to match org.springframework.util.xml;version="[3.2.9, 4.0.5)" (imported by mvn:org.springframework.data/spring-data-redis/1.3.4.RELEASE)
      [WARNING] No export found to match org.springframework.beans.factory;version="[3.2.9, 4.0.5)" (imported by mvn:org.springframework.data/spring-data-redis/1.3.4.RELEASE)
      [WARNING] No export found to match org.springframework.core.task;version="[3.2.9, 4.0.5)" (imported by mvn:org.springframework.data/spring-data-redis/1.3.4.RELEASE)
      [WARNING] No export found to match org.springframework.beans.factory.config;version="[3.2.9, 4.0.5)" (imported by mvn:org.springframework.data/spring-data-redis/1.3.4.RELEASE)
      [WARNING] No export found to match org.springframework.cache;version="[3.2.9, 4.0.5)" (imported by mvn:org.springframework.data/spring-data-redis/1.3.4.RELEASE)
      [WARNING] No export found to match org.springframework.core;version="[3.2.9, 4.0.5)" (imported by mvn:org.springframework.data/spring-data-redis/1.3.4.RELEASE)
      [WARNING] No export found to match org.springframework.core.convert;version="[3.2.9, 4.0.5)" (imported by mvn:org.springframework.data/spring-data-redis/1.3.4.RELEASE)
      [WARNING] No export found to match org.springframework.beans.factory.xml;version="[3.2.9, 4.0.5)" (imported by mvn:org.springframework.data/spring-data-redis/1.3.4.RELEASE)
      [WARNING] No export found to match org.springframework.dao.support;version="[3.2.9, 4.0.5)" (imported by mvn:org.springframework.data/spring-data-redis/1.3.4.RELEASE)
      

      Upgrading to version 1.4.0.RELEASE isn't an option at present, because it's not a valid OSGI bundle:

      cmueller$ mvn install -Pvalidate
      ...
      [ERROR] Failed to execute goal org.apache.karaf.tooling:features-maven-plugin:2.3.7:validate (validate) on project apache-camel: Unable to validate /Users/cmueller/workspaceCamel/camel/platforms/karaf/features/target/classes/features.xml: invalid version range: [4.0.6,4.0.6) -> [Help 1]
      

      Attachments

        Activity

          People

            Unassigned Unassigned
            muellerc Christian Müller
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: