Camel
  1. Camel
  2. CAMEL-727

Propagated CXF header's value should not include quotes

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.3.0
    • Fix Version/s: 1.4.0
    • Component/s: camel-cxf
    • Labels:
      None

      Description

      CAMEL-686 fixed the issue of not propagating transport headers (e.g. SOAPAction) but it looks like we added quotes around the value (i.e. getCustomer becomes "getCustomer"). I updated the CustomerServicesTest to illustrate the problem. Also, I cleaned up the client/server-application.xml.

      1. test_patch.txt
        7 kB
        William Tam

        Activity

        William Tam added a comment - - edited

        It is not a bug as the quotes came from CXF. CXF puts quotes around the SOAPAction's value. Anyway, I think we should apply the patch to verify header values in the test because activemq does not look for SOAPAction header (like TIBCO EMS) so the old test was not verifying the header propagation functionality.

        Willem Jiang added a comment -

        Applied test patch with thanks to William.

        http://svn.apache.org/viewvc?rev=677156&view=rev


          People

          • Assignee:
            Willem Jiang
            Reporter:
            William Tam
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development