Uploaded image for project: 'Camel'
  1. Camel
  2. CAMEL-6526

@Webfault details are not set in transacted routes

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Minor
    • Resolution: Unresolved
    • Affects Version/s: 2.11.0
    • Fix Version/s: Future
    • Component/s: camel-cxf
    • Labels:
      None
    • Estimated Complexity:
      Unknown

      Description

      In a transacted route, checked exceptions are wrapped by a RuntimeCamelException - the CxfConsumer should use the wrapped cause as fault, if it exists.

        Issue Links

          Activity

          davsclaus Claus Ibsen added a comment -

          Ah so somewhere in the cxf consumer it grabs the caused exception and uses that as a soap fault?

          And are you saying that it picks the wrong exception such as RuntimeCamelException instead of the real cause? Yeah sounds like we should grab the deepest child exception.

          davsclaus Claus Ibsen added a comment -

          Can you provide an example, unit test or something?

          davsclaus Claus Ibsen added a comment -

          Its more a CXF issue with that linked ticket that is unresolved after 5 years


            People

            • Assignee:
              Unassigned
              Reporter:
              pleibiger Peter Leibiger
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development