Camel
  1. Camel
  2. CAMEL-5745

camel-test-blueprint - Add support for Aries Blueprint 1.0

    Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.11.0
    • Component/s: camel-test
    • Labels:
      None
    • Estimated Complexity:
      Unknown

      Description

      Aries Blueprint 1.0 dont work with POJOsr and camel-test-blueprint. This is needed for allowing our end users to do easy unit tests with the blueprint Camel apps.

        Activity

        Hide
        Claus Ibsen added a comment -

        Upgraded to pojosr 0.2.0 that supports osgi 4.3 and aries blueprint 1.0

        Show
        Claus Ibsen added a comment - Upgraded to pojosr 0.2.0 that supports osgi 4.3 and aries blueprint 1.0
        Hide
        Babak Vahdat added a comment -

        Just for the sake of house-keeping: the svn revision for the ticket was:

        http://svn.apache.org/viewvc?view=revision&revision=1402441

        As CAMEL-5746 is another ticket.

        Show
        Babak Vahdat added a comment - Just for the sake of house-keeping: the svn revision for the ticket was: http://svn.apache.org/viewvc?view=revision&revision=1402441 As CAMEL-5746 is another ticket.
        Hide
        Babak Vahdat added a comment -

        I fixed the broken build on the trunk after the upgrade to OSGi 4.3.0.

        Show
        Babak Vahdat added a comment - I fixed the broken build on the trunk after the upgrade to OSGi 4.3.0.
        Hide
        Claus Ibsen added a comment -

        Logged a ticket with POJOsr. As just by upgrading Aries from 0.3 to 1.0.0 causes this problem.
        https://code.google.com/p/pojosr/issues/detail?id=6

        Aries 0.3 works with OSGi 4.3, and upgraded Felix ConfigAdmin / PaxExam-TinyBundle et all.
        I have tried many combinations. But its only when using Aries 1.0.0 it wont work.

        Show
        Claus Ibsen added a comment - Logged a ticket with POJOsr. As just by upgrading Aries from 0.3 to 1.0.0 causes this problem. https://code.google.com/p/pojosr/issues/detail?id=6 Aries 0.3 works with OSGi 4.3, and upgraded Felix ConfigAdmin / PaxExam-TinyBundle et all. I have tried many combinations. But its only when using Aries 1.0.0 it wont work.

          People

          • Assignee:
            Claus Ibsen
            Reporter:
            Claus Ibsen
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development