Camel
  1. Camel
  2. CAMEL-563

"cxf" name conflict in the spring context

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.4.0
    • Component/s: camel-cxf
    • Labels:
      None

      Description

      When I try to use camel-cxf component in smx4, I still get exceptions like
      Exception in thread "SpringOsgiExtenderThread-9" org.apache.camel.ResolveEndpointFailedException: Failed to resolve endpoint: cxf:bean:routerEndpoint due to: org.apache.camel.RuntimeCamelException: Could not auto create component: cxf
      at org.apache.camel.impl.DefaultCamelContext.getEndpoint(DefaultCamelContext.java:262)
      at org.apache.camel.util.CamelContextHelper.getMandatoryEndpoint(CamelContextHelper.java:52)
      at org.apache.camel.model.RouteType.resolveEndpoint(RouteType.java:90)
      at org.apache.camel.impl.DefaultRouteContext.resolveEndpoint(DefaultRouteContext.java:98)
      at org.apache.camel.impl.DefaultRouteContext.resolveEndpoint(DefaultRouteContext.java:104)
      at org.apache.camel.model.FromType.resolveEndpoint(FromType.java:67)
      at org.apache.camel.impl.DefaultRouteContext.getEndpoint(DefaultRouteContext.java:73)
      at org.apache.camel.model.RouteType.addRoutes(RouteType.java:204)
      at org.apache.camel.model.RouteType.addRoutes(RouteType.java:81)
      at org.apache.camel.impl.DefaultCamelContext.startRouteDefinitions(DefaultCamelContext.java:451)
      at org.apache.camel.impl.DefaultCamelContext.doStart(DefaultCamelContext.java:443)
      at org.apache.camel.spring.SpringCamelContext.doStart(SpringCamelContext.java:149)
      at org.apache.camel.impl.ServiceSupport.start(ServiceSupport.java:47)
      at org.apache.camel.spring.SpringCamelContext.onApplicationEvent(SpringCamelContext.java:103)
      at org.springframework.context.event.SimpleApplicationEventMulticaster$1.run(SimpleApplicationEventMulticaster.java:78)
      at org.springframework.core.task.SyncTaskExecutor.execute(SyncTaskExecutor.java:49)
      at org.springframework.context.event.SimpleApplicationEventMulticaster.multicastEvent(SimpleApplicationEventMulticaster.java:76)
      at org.springframework.context.support.AbstractApplicationContext.publishEvent(AbstractApplicationContext.java:275)
      at org.springframework.context.support.AbstractApplicationContext.finishRefresh(AbstractApplicationContext.java:737)
      at org.springframework.osgi.context.support.AbstractDelegatedExecutionApplicationContext.finishRefresh(AbstractDelegatedExecutionApplicationContext.java:271)
      at org.springframework.osgi.context.support.AbstractDelegatedExecutionApplicationContext.completeRefresh(AbstractDelegatedExecutionApplicationContext.java:254)
      at org.springframework.osgi.extender.internal.dependencies.startup.DependencyWaiterApplicationContextExecutor$CompleteRefreshTask.run(DependencyWaiterApplicationContextExecutor.java:136)
      at java.lang.Thread.run(Thread.java:595)
      Caused by: org.apache.camel.RuntimeCamelException: Could not auto create component: cxf
      at org.apache.camel.impl.DefaultCamelContext.getComponent(DefaultCamelContext.java:149)
      at org.apache.camel.impl.DefaultCamelContext.getEndpoint(DefaultCamelContext.java:233)
      ... 22 more
      Caused by: java.lang.IllegalArgumentException: Bean with name: cxf in registry is not a Component: org.apache.cxf.bus.CXFBusImpl@3ca56f
      at org.apache.camel.osgi.OsgiComponentResolver.resolveComponent(OsgiComponentResolver.java:167)
      at org.apache.camel.impl.DefaultCamelContext.getComponent(DefaultCamelContext.java:138)
      ... 23 more

        Activity

        Freeman Fang created issue -
        Willem Jiang made changes -
        Field Original Value New Value
        Assignee Willem Jiang [ njiang ]
        Willem Jiang made changes -
        Status Open [ 1 ] In Progress [ 3 ]
        Willem Ning Jiang <ningjiang@apache.org> committed f4cbe124fa90b369ed51870c1ad312ef9c360692 (1 file)
        Reviews: none

        CAMEL-563 fixed the cxf name conflict in the osgi spring context
        git-svn-id: https://svn.apache.org/repos/asf/activemq/camel/trunk@661676 13f79535-47bb-0310-9956-ffa450edef68

        ningjiang committed 661676 (1 file)
        Reviews: none

        CAMEL-563 fixed the cxf name conflict in the osgi spring context

        Willem Jiang added a comment -

        we could let component be created by the resolver if we can't get the right component by looking up the context registry.
        Please check it out.

        Willem Jiang made changes -
        Status In Progress [ 3 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        Willem Jiang made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Jeff Turner made changes -
        Project Import Sat Nov 27 00:14:50 EST 2010 [ 1290834890113 ]

          People

          • Assignee:
            Willem Jiang
            Reporter:
            Freeman Fang
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development