Camel
  1. Camel
  2. CAMEL-548

File component should have option for deleting file if it was handled by an exception handler etc

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.3.0
    • Fix Version/s: 1.4.0
    • Component/s: camel-core
    • Labels:
      None

      Description

      See the user forum where a user has detailed the problem:

      http://www.nabble.com/File-Component-Error-handling-td15372041s22882.html

        Activity

        Drew McAuliffe added a comment -

        The trouble appears to start around line 119 in "FileConsumer" (on the 1.3 release), where the call to processStrategy.commit() never gets reach if an exception occurs during the asynch processor's processing.

        Claus Ibsen added a comment -

        A proposed patch that works, however I need a few more investigations

        Claus Ibsen added a comment -

        The problem is that the lock file is not deleted when the failure handler has handled the exception. The callback when this happens is not executing the code that deletes the lock file

        Claus Ibsen added a comment -

        Okay commitet but now needs dependency on DeadLetterChannel for a constant it exposes.

        Camel need some kind of addition to the ErrorHandler interface to let it be able to do failure processing also, or a helper method on exchange to expose if it was handled by a failure processor.


          People

          • Assignee:
            Claus Ibsen
            Reporter:
            Claus Ibsen
          • Votes:
            1 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development