Camel
  1. Camel
  2. CAMEL-5254

Camel Commands for the Karaf shell should work with Karaf 3

    Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.9.2
    • Fix Version/s: 2.9.3, 2.10.0
    • Component/s: None
    • Labels:
      None
    • Estimated Complexity:
      Unknown

      Description

      Currently camel-core can not be installed into Karaf 3. The error message is that the shell.console package it imports is in version 3.0.0 in karaf 3.
      Our import range is [2.2-3) though. So we should change the import to [2.2-4).

      Currently this does not work with Karaf 3 but I will make sure Karaf 3 will be compatible to the current camel commands.
      It is important to do the import range change now so camel 2.10.0 is later compatible.

        Issue Links

          Activity

          Hide
          Christian Schneider added a comment -

          Linking to the related issue in karaf

          Show
          Christian Schneider added a comment - Linking to the related issue in karaf
          Hide
          Christian Schneider added a comment -

          Import range increased. This will only actually work as soon as the linked karaf issue is resolved

          Show
          Christian Schneider added a comment - Import range increased. This will only actually work as soon as the linked karaf issue is resolved

            People

            • Assignee:
              Christian Schneider
              Reporter:
              Christian Schneider
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development