Camel
  1. Camel
  2. CAMEL-5237

Move camel-jibx to camel-extra or remove it or whatever

    Details

    • Type: Task Task
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: Future
    • Component/s: None
    • Labels:
      None
    • Estimated Complexity:
      Unknown

      Description

      The camel-jibx component uses some jibx plugin that cannot find its dependencies in any maven repo, and we get issues when building the source.

      Just getting tired of maintaining this not used component, causing build to fail due artifacts not in reliable maven repos.

        Activity

        Christian Müller added a comment -

        I back ported this to Camel 2.8.x and 2.9.x as well:
        rev1354732
        rev1354724

        Henryk Konsek made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Assignee Henryk Konsek [ hekonsek ] Claus Ibsen [ davsclaus ]
        Resolution Fixed [ 1 ]
        Henryk Konsek added a comment - - edited

        Daniel fixed this issue by upgrading Jibx to the latest version.

        rev1353651

        ningjiang committed 1347882 (1 file)
        Willem Ning Jiang <ningjiang@apache.org> committed 503ca1fb0f1a63a86a8c7dad2e4284f43a975422 (1 file)
        Reviews: none

        CAMEL-5237 clean up the camel-hdfs feature
        git-svn-id: https://svn.apache.org/repos/asf/camel/trunk@1347882 13f79535-47bb-0310-9956-ffa450edef68

        Henryk Konsek made changes -
        Assignee Henryk Konsek [ hekonsek ]
        Claus Ibsen made changes -
        Field Original Value New Value
        Fix Version/s 2.10.0 [ 12317612 ]
        Henryk Konsek added a comment -

        Actually even just now (in the project I'm working in) I've run on the case where I need to use camel-jibx again. I work a lot with high-throughput XML processing (where I make heavy use of Jibx) so I find Jibx data format very useful .

        Henryk Konsek added a comment -

        Hi guys,

        I'll happy to help you with that since I use this module in some production projects. It will be a little problem for me if you remove this data format from Camel trunk.

        What artifacts jibx-plugin misses? I'm building (mvn clean install) the camel-jibx (against the clean local Maven repository and with no settings.xml) and module is built correctly. In particular 3rd party artifacts are downloaded from the public repo [1]. I cannot reproduce the issue - could you help me with that?

        [1] http://repo.maven.apache.org/maven2/org/jibx/config/3rdparty

        Daniel Kulp added a comment -

        I'd also emphasize that if we do this for jibx, we should do this for the other components that are using artifacts not at Central. There are a bunch of them.

        Hadrian Zbarcea added a comment -

        I'd first try to get in touch with Dennis or Nigel, but I think ultimately that's what we need to do.

        Claus Ibsen created issue -

          People

          • Assignee:
            Claus Ibsen
            Reporter:
            Claus Ibsen
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development