Camel
  1. Camel
  2. CAMEL-5227

Camel 2.9.2 jetty component no longer works with Jetty 7

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 2.9.2
    • Fix Version/s: 2.9.3, 2.10.0
    • Component/s: camel-jetty
    • Labels:
      None
    • Estimated Complexity:
      Novice
    • Regression:
      Regression

      Description

      When attempting to create a camel-jetty endpoint in Camel 2.9.2, the following exception is thrown:

      java.lang.NoSuchMethodError: org.eclipse.jetty.servlet.ServletContextHandler.addFilter(Lorg/eclipse/jetty/servlet/FilterHolder;Ljava/lang/String;Ljava/util/EnumSet;)V
      at org.apache.camel.component.jetty.JettyHttpComponent.enableMultipartFilter(JettyHttpComponent.java:407)
          at org.apache.camel.component.jetty.JettyHttpComponent.connect(JettyHttpComponent.java:325)
          at org.apache.camel.component.http.HttpEndpoint.connect(HttpEndpoint.java:148)
          at org.apache.camel.component.http.HttpConsumer.doStart(HttpConsumer.java:56)
          at org.apache.camel.support.ServiceSupport.start(ServiceSupport.java:60)
          at org.apache.camel.impl.DefaultCamelContext.startService(DefaultCamelContext.java:1707)
          at org.apache.camel.impl.DefaultCamelContext.doStartOrResumeRouteConsumers(DefaultCamelContext.java:1979)
          at org.apache.camel.impl.DefaultCamelContext.doStartRouteConsumers(DefaultCamelContext.java:1934)
          at org.apache.camel.impl.DefaultCamelContext.safelyStartRouteServices(DefaultCamelContext.java:1862)
          at org.apache.camel.impl.DefaultCamelContext.doStartOrResumeRoutes(DefaultCamelContext.java:1646)
          at org.apache.camel.impl.DefaultCamelContext.doStartCamel(DefaultCamelContext.java:1533)
          at org.apache.camel.impl.DefaultCamelContext.doStart(DefaultCamelContext.java:1420)
          at org.apache.camel.spring.SpringCamelContext.doStart(SpringCamelContext.java:179)
          at org.apache.camel.support.ServiceSupport.start(ServiceSupport.java:60)
          at org.apache.camel.impl.DefaultCamelContext.start(DefaultCamelContext.java:1388)
      .
      .
      .
      

      This appears to be a regression of a caused by the this merge from trunk, which I suspect requires Jetty 8 to be used.

      Creating the endpoint under 2.9.1 works fine.

        Issue Links

          Activity

          Claus Ibsen added a comment -

          What version of Jetty are you using?

          Claus Ibsen added a comment -
          Claus Ibsen added a comment -

          I have reverted rev 1307901 on the 2.9 branch so the API is compatible with Jetty 7 again. This is the version we support on the 2.9 branch.

          Claus Ibsen added a comment -

          I am inclined to do the same on the Camel trunk as we are not supporting Jetty 8 currently. Jetty is hard to upgrade as many other projects depend on it, CXF, AMQ, Karaf etc.

          Claus Ibsen added a comment -

          Thanks for reporting. I have reverted the change on Camel trunk so Camel 2.10 is Jetty 7 API compatible again.

          Scott Parkerson added a comment -

          Verified as fixed in 2.9.3-SNAPSHOT. Thank you!


            People

            • Assignee:
              Claus Ibsen
              Reporter:
              Scott Parkerson
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development