Camel
  1. Camel
  2. CAMEL-5131

camel-hdfs feature does not work as it refers to jetty-bundle-version which does not resolve

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.9.2
    • Component/s: camel-hdfs
    • Labels:
      None
    • Estimated Complexity:
      Unknown

      Description

      In the feature file the camel-hdfs feature loads the bundle:
      <bundle>mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.jetty/$

      {jetty6-bundle-version}

      </bundle>

      As jetty-bundle-version is not defined that does not work.

      I see two possible solutions:
      1. use jetty-version instead
      2. Remove the bundle as the feature also loads the war feature which should load jetty

      I will try to fix with variant 1. Does anyone know why we need the bundle if we have the war feature?

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        55m 1 Christian Schneider 29/Mar/12 15:12
        Christian Schneider made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        Christian Schneider made changes -
        Field Original Value New Value
        Description In the feature file the camel-hdfs feature loads the bundle:
        <bundle>mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.jetty/${jetty6-bundle-version}</bundle>

        As jetty-bundle-version is not defined that does not work.

        I see two possible solutions:
        1. use jetty-version instead
        2. Remove the bundle as the feature also loads the war feature which should load jetty

        I will try to fix with variant two.
        In the feature file the camel-hdfs feature loads the bundle:
        <bundle>mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.jetty/${jetty6-bundle-version}</bundle>

        As jetty-bundle-version is not defined that does not work.

        I see two possible solutions:
        1. use jetty-version instead
        2. Remove the bundle as the feature also loads the war feature which should load jetty

        I will try to fix with variant 1. Does anyone know why we need the bundle if we have the war feature?
        Christian Schneider created issue -

          People

          • Assignee:
            Christian Schneider
            Reporter:
            Christian Schneider
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development