Camel
  1. Camel
  2. CAMEL-5016

Support the Jetty8 API of ServletContextHandler.addFilter

    Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.9.3, 2.10.0
    • Component/s: camel-jetty
    • Labels:
      None
    • Estimated Complexity:
      Unknown

      Issue Links

        Activity

        Hide
        Willem Jiang added a comment -

        Applied the patch into trunk.

        Show
        Willem Jiang added a comment - Applied the patch into trunk.
        Hide
        Claus Ibsen added a comment -

        Have to revert this as we cannot support the API of Jetty 7 and 8 at the same time. This breaks for people using Jetty 7.

        Show
        Claus Ibsen added a comment - Have to revert this as we cannot support the API of Jetty 7 and 8 at the same time. This breaks for people using Jetty 7.
        Hide
        Claus Ibsen added a comment -

        Dan there is also this ticket.

        Show
        Claus Ibsen added a comment - Dan there is also this ticket.

          People

          • Assignee:
            Daniel Kulp
            Reporter:
            Willem Jiang
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development