Camel
  1. Camel
  2. CAMEL-4999

Upgrade from 2.8.3 to 2.9.0 breaks the schema validation capability in the Camel Validation component

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.9.0
    • Fix Version/s: 2.9.1
    • Component/s: camel-core
    • Labels:
      None
    • Estimated Complexity:
      Unknown

      Description

      A Camel user reported the following in the Camel User Forum issue
      http://camel.465427.n5.nabble.com/Validation-error-after-upgrade-from-Camel-2-8-3-to-2-9-0-td5472816.html

      Details
      --------
      I have a route that use
      http://camel.apache.org/validation.html

      after upgrade Camel from 2.8.3 to 2.9.0 during validation I receive
      the following error
      by: org.xml.sax.SAXParseException: src-resolve: Cannot resolve the
      name 'ecc:PositionType' to a 'type definition' component.
      at org.apache.xerces.util.ErrorHandlerWrapper.createSAXParseException(Unknown
      Source)[:]
      at org.apache.xerces.util.ErrorHandlerWrapper.error(Unknown Source)[:]
      at org.apache.xerces.impl.XMLErrorReporter.reportError(Unknown Source)[:]
      at org.apache.xerces.impl.xs.traversers.XSDHandler.reportSchemaError(Unknown
      Source)[:]
      at org.apache.xerces.impl.xs.traversers.XSDHandler.reportSchemaError(Unknown
      Source)[:]
      at org.apache.xerces.impl.xs.traversers.XSDHandler.getGlobalDecl(Unknown
      Source)[:]
      at org.apache.xerces.impl.xs.traversers.XSDElementTraverser.traverseNamedElement(Unknown
      Source)[:]
      at org.apache.xerces.impl.xs.traversers.XSDElementTraverser.traverseLocal(Unknown
      Source)[:]
      at org.apache.xerces.impl.xs.traversers.XSDHandler.traverseLocalElements(Unknown
      Source)[:]
      at org.apache.xerces.impl.xs.traversers.XSDHandler.parseSchema(Unknown
      Source)[:]
      at org.apache.xerces.impl.xs.XMLSchemaLoader.loadSchema(Unknown Source)[:]
      at org.apache.xerces.impl.xs.XMLSchemaLoader.loadGrammar(Unknown Source)[:]
      at org.apache.xerces.impl.xs.XMLSchemaLoader.loadGrammar(Unknown Source)[:]
      at org.apache.xerces.jaxp.validation.XMLSchemaFactory.newSchema(Unknown
      Source)[:]
      at javax.xml.validation.SchemaFactory.newSchema(SchemaFactory.java:524)[:]
      at org.apache.camel.processor.validation.ValidatingProcessor.createSchema(ValidatingProcessor.java:231)[90:org.apache.camel.camel-core:2.9.0]
      at org.apache.camel.processor.validation.ValidatingProcessor.loadSchema(ValidatingProcessor.java:105)[90:org.apache.camel.camel-core:2.9.0]
      at org.apache.camel.component.validator.ValidatorComponent.createEndpoint(ValidatorComponent.java:55)[90:org.apache.camel.camel-core:2.9.0]
      at org.apache.camel.impl.DefaultComponent.createEndpoint(DefaultComponent.java:91)[90:org.apache.camel.camel-core:2.9.0]
      at org.apache.camel.impl.DefaultCamelContext.getEndpoint(DefaultCamelContext.java:432)[90:org.apache.camel.camel-core:2.9.0]

        Activity

        Ashwin Karpe created issue -
        filippo balicchia added a comment -

        After some unit test i see that the problem is fixed in version 2.10-SNAPSHOT.
        The jira issue that fix the problem is:
        CAMEL-4877: Validator component now supports xs:import again.

        The version of camel that has this from are 2.9.0 and 2.9.0-RC1.

        From my point of view this iusse can be closed

        Thanks from help

        Claus Ibsen added a comment -

        Already fixed

        Claus Ibsen made changes -
        Field Original Value New Value
        Status Open [ 1 ] Resolved [ 5 ]
        Assignee Claus Ibsen [ davsclaus ]
        Fix Version/s 2.9.1 [ 12319191 ]
        Resolution Fixed [ 1 ]

          People

          • Assignee:
            Claus Ibsen
            Reporter:
            Ashwin Karpe
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development