Camel
  1. Camel
  2. CAMEL-4997

Method call expression with bean type uses the toString to lookup a bean instead

    Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.8.4, 2.9.0
    • Fix Version/s: 2.9.1, 2.10.0
    • Component/s: camel-core
    • Labels:
      None
    • Estimated Complexity:
      Unknown

      Activity

      Claus Ibsen created issue -
      Claus Ibsen made changes -
      Field Original Value New Value
      Fix Version/s 2.8.5 [ 12319522 ]
      Affects Version/s 2.9.0 [ 12316374 ]
      Affects Version/s 2.8.4 [ 12319072 ]
      Claus Ibsen added a comment -

      This is actually not a bug. The compiler picks the (Object) parameter. You would have to type cast to Class if you want to explicit chose that method.
      I will improve Camel to detect the Class type for the Object parameter.

      Claus Ibsen made changes -
      Issue Type Bug [ 1 ] Improvement [ 4 ]
      Fix Version/s 2.8.5 [ 12319522 ]
      Claus Ibsen made changes -
      Status Open [ 1 ] Resolved [ 5 ]
      Resolution Fixed [ 1 ]
      Transition Time In Source Status Execution Times Last Executer Last Execution Date
      Open Open Resolved Resolved
      2d 19h 56m 1 Claus Ibsen 12/Feb/12 10:51

        People

        • Assignee:
          Claus Ibsen
          Reporter:
          Claus Ibsen
        • Votes:
          0 Vote for this issue
          Watchers:
          0 Start watching this issue

          Dates

          • Created:
            Updated:
            Resolved:

            Development