Camel
  1. Camel
  2. CAMEL-4955

Camel should run in a Java 7 environment

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 2.9.0
    • Fix Version/s: 2.10.0
    • Component/s: None
    • Labels:
      None
    • Estimated Complexity:
      Unknown

      Description

      End of life for Java 6 is July 2012.
      If we release Camel 2.10.0 3 month after 2.9.0, it's round about March/April. The next Camel release after 2.10.0 (may be 3.0.0) will be not available before July 2012.
      Because of this, I think Camel 2.10.0 must be able to run in an Java 7 environment to give our users the possibility to migrate to Java 7 before it reaches EOL.

      http://www.oracle.com/technetwork/java/eol-135779.html

        Issue Links

          Activity

          No work has yet been logged on this issue.

            People

            • Assignee:
              Christian Müller
              Reporter:
              Christian Müller
            • Votes:
              5 Vote for this issue
              Watchers:
              9 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development