Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Not a Problem
    • Affects Version/s: 2.9.0
    • Fix Version/s: 2.9.0
    • Component/s: karaf
    • Labels:
    • Estimated Complexity:
      Unknown

      Description

      Christian-Muellers-MacBook-Pro:bin cmueller$ /Applications/apache-karaf-2.2.5/bin/karaf clean
      __ __ ____
      / ///___ __________ _/ __/
      / ,< / __ `/ __/ __ `/ /
      / /| |/ // / / / // / __/
      // ||_,// _,//

      Apache Karaf (2.2.5)

      Hit '<tab>' for a list of available commands
      and '[cmd] --help' for help on a specific command.
      Hit '<ctrl-d>' or 'osgi:shutdown' to shutdown Karaf.

      karaf@root> features:addurl mvn:org.apache.camel.karaf/apache-camel/2.9-SNAPSHOT/xml/features
      karaf@root> features:install camel-cxf
      2011-12-27 21:39:05.855:INFO:oejs.Server:jetty-7.5.4.v20111024
      2011-12-27 21:39:05.877:INFO:oejs.AbstractConnector:Started SelectChannelConnector@0.0.0.0:8181 STARTING
      2011-12-27 21:39:06.061:INFO:oejsh.ContextHandler:started HttpServiceContext{httpContext=DefaultHttpContext{bundle=org.apache.karaf.deployer.features [34]}}
      2011-12-27 21:39:07.441:INFO:oejsh.ContextHandler:stopped HttpServiceContext{httpContext=DefaultHttpContext{bundle=org.apache.karaf.deployer.features [34]}}
      Error executing command: Could not start bundle mvn:org.apache.cxf/cxf-bundle/2.5.1 in feature(s) cxf-2.5.1: Unable to resolve module org.apache.cxf.bundle [136.0] because it is exposed to package 'javax.xml.bind.attachment' from org.apache.felix.framework [0] and org.apache.servicemix.specs.jaxb-api-2.2 [65.0] via two dependency chains.

      Chain 1:
      org.apache.cxf.bundle [136.0]
      import: (&(package=javax.xml.bind.attachment)(version>=0.0.0)(!(version>=3.0.0)))

      export: package=javax.xml.bind.attachment
      org.apache.felix.framework [0]

      Chain 2:
      org.apache.cxf.bundle [136.0]
      import: (package=com.sun.tools.xjc.reader.xmlschema.parser)

      export: package=com.sun.tools.xjc.reader.xmlschema.parser; uses:=javax.xml.bind
      org.apache.servicemix.bundles.jaxb-xjc [95.0]
      import: (&(package=javax.xml.bind)(version>=2.2.0)(!(version>=3.0.0)))

      export: package=javax.xml.bind; uses:=javax.xml.bind.attachment
      export: package=javax.xml.bind.attachment
      org.apache.servicemix.specs.jaxb-api-2.2 [65.0]

        Activity

          People

          • Assignee:
            Unassigned
            Reporter:
            Christian Müller
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development