Details

    • Type: Task Task
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Implemented
    • Affects Version/s: 2.8.3
    • Fix Version/s: 2.13.0
    • Component/s: camel-zookeeper
    • Labels:
      None
    • Estimated Complexity:
      Unknown

      Description

      We currently use 3.3.x. We should upgrade to the 3.4.x branch.

        Issue Links

          Activity

          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open Resolved Resolved
          32m 33s 1 Claus Ibsen 20/Dec/11 10:30
          Resolved Resolved Reopened Reopened
          5h 40m 1 Claus Ibsen 20/Dec/11 16:11
          Reopened Reopened Resolved Resolved
          802d 19h 18m 1 Claus Ibsen 02/Mar/14 11:30
          Claus Ibsen made changes -
          Status Reopened [ 4 ] Resolved [ 5 ]
          Assignee Claus Ibsen [ davsclaus ]
          Fix Version/s 2.13.0 [ 12324786 ]
          Fix Version/s Future [ 12315692 ]
          Resolution Implemented [ 10 ]
          Claus Ibsen added a comment -

          We have upgraded to 3.4.x

          Claus Ibsen added a comment -

          Zookeeper 3.4.6 has some OSGi fixes so hope they get it released.

          Gavin made changes -
          Link This issue depends upon ZOOKEEPER-1334 [ ZOOKEEPER-1334 ]
          Gavin made changes -
          Link This issue depends on ZOOKEEPER-1334 [ ZOOKEEPER-1334 ]
          Claus Ibsen made changes -
          Fix Version/s Future [ 12315692 ]
          Fix Version/s 2.11.0 [ 12321695 ]
          Claus Ibsen added a comment -

          The Zookeeper have still not listen. We are about 1 year later, and they keep releasing Zookeeper with flawed OSGi meta-data, despite a fix is fairly easy.

          Claus Ibsen made changes -
          Fix Version/s 2.11 [ 12321695 ]
          Fix Version/s 2.10.0 [ 12317612 ]
          Claus Ibsen made changes -
          Assignee Claus Ibsen [ davsclaus ]
          Claus Ibsen made changes -
          Link This issue depends on ZOOKEEPER-1334 [ ZOOKEEPER-1334 ]
          Claus Ibsen added a comment -

          The problem is the Zookeeper distribution. I have logged a JIRA
          https://issues.apache.org/jira/browse/ZOOKEEPER-1334

          Claus Ibsen made changes -
          Fix Version/s 2.10 [ 12317612 ]
          Fix Version/s 2.9.0 [ 12316374 ]
          Claus Ibsen added a comment -

          Due to osgi pain lets move this after the 2.9.0 release.

          We get really weird osgi problems with zookeeper 3.4.x and whatnot.

          Claus Ibsen made changes -
          Resolution Fixed [ 1 ]
          Status Resolved [ 5 ] Reopened [ 4 ]
          Claus Ibsen added a comment -

          A fix has been committed to trunk.

          Claus Ibsen added a comment -

          Thanks Babak, I will look into it.

          Hadrian Zbarcea made changes -
          Fix Version/s 2.9.0 [ 12316374 ]
          Fix Version/s 2.10 [ 12317612 ]
          Affects Version/s 2.8.3 [ 12318649 ]
          Affects Version/s 2.9.0 [ 12316374 ]
          Claus Ibsen made changes -
          Field Original Value New Value
          Status Open [ 1 ] Resolved [ 5 ]
          Assignee Claus Ibsen [ davsclaus ]
          Resolution Fixed [ 1 ]
          Claus Ibsen added a comment -

          Upgraded to zookeeper 3.4.1

          Claus Ibsen created issue -

            People

            • Assignee:
              Claus Ibsen
              Reporter:
              Claus Ibsen
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development