Camel
  1. Camel
  2. CAMEL-4714

Improvements to camel-example-cxf-tomcat sample

    Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.9.0
    • Component/s: examples
    • Labels:
      None
    • Patch Info:
      Patch Available
    • Estimated Complexity:
      Unknown

      Description

      Hi, attached patch makes the following changes to the camel-example-cxf-tomcat sample:

      1.) Reactivates the client call (mvn exec:java now enabled); README updated.
      2.) In the README, provides sample SOAP requests for usage via soapUI.
      3.) Allows for optional faster deployment of the WAR via mvn tomcat:deploy (for TC7) or mvn tomcat:deploy -PTomcat6 (TC6) instead
      of just manually copying the WAR to the webapps folder.
      4.) Removed the resource filtering (as the client Java file was missing it and hence not working, and there's enough of a case
      that SOAP web service providers shouldn't have a version # in the deployed WAR) in favor of a hardcoded
      "camel-example-cxf-tomcat" WAR file name.

        Activity

        Glen Mazza added a comment -

        Hold off on this patch, unfortunately. Because we release the WAR to the central repository we might be required to include the version within the WAR file name. I'll look into it.

        Willem Jiang added a comment -

        Hi Glen,

        I saw you comment after I committed the patch.
        Now I just reverted the patch which moved the version of war.

        Please feel free to do the other enhancement if you need.

        Cheers,

        Willem

        Glen Mazza added a comment -

        Willem, I apologize, the patch is good without any changes needed. I just confirmed, if I use <build>...<finalName>foo</finalName></build> in the pom.xml, I'll get foo.war in the target directory (good for local deployment, client can always access it: http://localhost:8080/foo/...) but Maven will nicely still add the version number and timestamp (foo-1.2.3-SNAPSHOT.war) when it places it in the repo.

        There's enough of a use case to not placing the version number in the deployed war (namely, so client endpoints won't need updating each time the webapp changes to a new version number) that I think the example is good using <finalName/>. Someone might wish to revert back to resource filtering to deploy WARs w/version numbers but that can be done at a later date.

        Willem Jiang added a comment -

        Applied the full patch with thanks of Glen.


          People

          • Assignee:
            Willem Jiang
            Reporter:
            Glen Mazza
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development