Camel
  1. Camel
  2. CAMEL-4695

Calling the camel-smpp component results in a NullPointerException

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.9.0
    • Component/s: camel-smpp
    • Labels:
      None
    • Estimated Complexity:
      Unknown

      Description

      When the camel-smpp component is called to submit a SMS, a NullPointerException is thrown:

      Stacktrace
      Caused by: java.lang.NullPointerException
             at org.jsmpp.util.PDUByteBuffer.appendAll(PDUByteBuffer.java:182)[149:org.apache.servicemix.bundles.jsmpp:2.1.0.3]
             at org.jsmpp.util.DefaultComposer.submitSm(DefaultComposer.java:238)[149:org.apache.servicemix.bundles.jsmpp:2.1.0.3]
             at org.jsmpp.DefaultPDUSender.sendSubmitSm(DefaultPDUSender.java:196)[149:org.apache.servicemix.bundles.jsmpp:2.1.0.3]
             at org.jsmpp.SynchronizedPDUSender.sendSubmitSm(SynchronizedPDUSender.java:192)[149:org.apache.servicemix.bundles.jsmpp:2.1.0.3]
             at org.jsmpp.session.SubmitSmCommandTask.executeTask(SubmitSmCommandTask.java:86)[149:org.apache.servicemix.bundles.jsmpp:2.1.0.3]
             at org.jsmpp.session.AbstractSession.executeSendCommand(AbstractSession.java:248)[149:org.apache.servicemix.bundles.jsmpp:2.1.0.3]
             at org.jsmpp.session.SMPPSession.submitShortMessage(SMPPSession.java:320)[149:org.apache.servicemix.bundles.jsmpp:2.1.0.3]
             at org.apache.camel.component.smpp.SmppSubmitSmCommand.execute(SmppSubmitSmCommand.java:56)
             ... 62 more
      

        Activity

        Christian Müller added a comment -

        It's easy if you have a look at the change set Claus mentioned [1]. The fix is also back ported to the camel-2.8.x maintenance branch...

        [1] https://fisheye6.atlassian.com/changelog/camel?cs=1165993

        Ruslan added a comment -

        Ok, but the fix has been done in new SmppSubmitSmCommand file

        Where do I add this fix in 2.8.0 version?

        Claus Ibsen added a comment -

        Yes you can patch the code yourself. Click the Source tab on this ticket to see the code changes.

        Ruslan added a comment -

        Christian, how this issue has been resolved? Can I patch 2.8.0 version?

        Daniel Kulp committed 1222333 (1 file)
        Reviews: none

        Blocked revisions 1203887,1205724,1206054-1206055,1206115,1206397,1206424,1206429,1206431-1206432,1206456,1206461,1206470,1206659,1206967,1207000,1207097,1207287,1208298,1208443,1208903,1208953,1209005,1209178-1209179,1209333,1209353,1209375,1209391-1209392,1209403-1209404,1209457,1209585,1209589 via svnmerge

        ........
          r1203887 | cmueller | 2011-11-18 17:33:19 -0500 (Fri, 18 Nov 2011) | 1 line
          
          CAMEL-4695: Calling the camel-smpp component results in a NullPointerException
        ........
          r1205724 | hadrian | 2011-11-24 00:21:00 -0500 (Thu, 24 Nov 2011) | 1 line
          
          CAMEL-4709. Disable failing hawtdb osgi test
        ........
          r1206054 | ningjiang | 2011-11-24 23:11:18 -0500 (Thu, 24 Nov 2011) | 1 line
          
          Using the cxf-jaxb feature to install the xml related api bundles
        ........
          r1206055 | ningjiang | 2011-11-24 23:13:30 -0500 (Thu, 24 Nov 2011) | 1 line
          
          Added a dynamic route test based on the user forum.
        ........
          r1206115 | ningjiang | 2011-11-25 05:31:36 -0500 (Fri, 25 Nov 2011) | 1 line
          
          Removed the System.out.println of the test
        ........
          r1206397 | hadrian | 2011-11-25 23:22:09 -0500 (Fri, 25 Nov 2011) | 1 line
          
          Minor improvement around test time and use logging instead of system out
        ........
          r1206424 | davsclaus | 2011-11-26 05:36:16 -0500 (Sat, 26 Nov 2011) | 1 line
          
          CAMEL-4514: Added onRemove callback to RoutePolicy. Thanks to Bilgin for the patch.
        ........
          r1206429 | davsclaus | 2011-11-26 06:40:14 -0500 (Sat, 26 Nov 2011) | 1 line
          
          CAMEL-4574: Log and Tracer have maxChars at 10000 by default to avoid logging very big data.
        ........
          r1206431 | davsclaus | 2011-11-26 07:22:00 -0500 (Sat, 26 Nov 2011) | 1 line
          
          CAMEL-4161: camel-mail no longer dep on Spring JARs.
        ........
          r1206432 | davsclaus | 2011-11-26 07:43:37 -0500 (Sat, 26 Nov 2011) | 1 line
          
          camel-mybatis feature not dep on spring
        ........
          r1206456 | davsclaus | 2011-11-26 10:15:28 -0500 (Sat, 26 Nov 2011) | 1 line
          
          CAMEL-4716: Polished camel-quickfix to remove dep on Spring JAR
        ........
          r1206461 | davsclaus | 2011-11-26 10:44:32 -0500 (Sat, 26 Nov 2011) | 1 line
          
          CAMEL-4716: camel-quickfix no longer depend on Spring JARs.
        ........
          r1206470 | davsclaus | 2011-11-26 11:05:01 -0500 (Sat, 26 Nov 2011) | 1 line
          
          Removed not needed Spring JAR dep.
        ........
          r1206659 | hadrian | 2011-11-26 22:26:31 -0500 (Sat, 26 Nov 2011) | 1 line
          
          Minor tests fix, test generated files should go in target/
        ........
          r1206967 | ningjiang | 2011-11-27 22:45:38 -0500 (Sun, 27 Nov 2011) | 1 line
          
          CAMEL-4714 Improvements to camel-example-cxf-tomcat sample
        ........
          r1207000 | ningjiang | 2011-11-28 02:28:09 -0500 (Mon, 28 Nov 2011) | 1 line
          
          CAMEL-4714 revert the change which remove the version of the war
        ........
          r1207097 | jstrachan | 2011-11-28 07:12:10 -0500 (Mon, 28 Nov 2011) | 1 line
          
          Fixes CAMEL-4719 so camel-web works better inside WebLogic; avoiding the use of the scalate console unless its present and in debig mode and having a precompiled error page to avoid unnecessary runtime compilation of scalate templates. Also used the simpler scalate filter which adds support for jade, markdown, confluence etc easier with less boilerplate XML in web.xml
        ........
          r1207287 | ningjiang | 2011-11-28 10:16:45 -0500 (Mon, 28 Nov 2011) | 1 line
          
          Clean up the camel-scala unit tests
        ........
          r1208298 | ningjiang | 2011-11-30 01:50:26 -0500 (Wed, 30 Nov 2011) | 1 line
          
          CAMEL-4728 Add setDefaultEndpoint method on the interface of ProducerTemplate
        ........
          r1208443 | ningjiang | 2011-11-30 09:12:09 -0500 (Wed, 30 Nov 2011) | 1 line
          
          Fixed the svn:ignore property issue of camel-jclouds
        ........
          r1208903 | dvaleri | 2011-11-30 19:13:30 -0500 (Wed, 30 Nov 2011) | 1 line
          
          [CAMEL-4720] Add support for Camel JSSE Configuration Util to FTPS component.
        ........
          r1208953 | hadrian | 2011-12-01 00:07:50 -0500 (Thu, 01 Dec 2011) | 1 line
          
          Minor test fixes
        ........
          r1209005 | ningjiang | 2011-12-01 03:54:13 -0500 (Thu, 01 Dec 2011) | 1 line
          
          Fix a CS error of camel-itest
        ........
          r1209178 | davsclaus | 2011-12-01 13:46:45 -0500 (Thu, 01 Dec 2011) | 1 line
          
          Upgraded to zookeeper 3.3.4
        ........
          r1209179 | davsclaus | 2011-12-01 13:48:06 -0500 (Thu, 01 Dec 2011) | 1 line
          
          CAMEL-4722: Polished example. Thanks to Glen Mazza for the patch.
        ........
          r1209333 | boday | 2011-12-01 21:33:04 -0500 (Thu, 01 Dec 2011) | 1 line
          
          CAMEL-4539: adds the camel-solr component (thanks to Alex Cowell and Bilgin Ibryam for the initial patch). enhancements added to include more Solr operations and Karaf features support
        ........
          r1209353 | hadrian | 2011-12-01 22:32:42 -0500 (Thu, 01 Dec 2011) | 1 line
          
          CAMEL-3371. Reopened issue and temporarily commented out failing tests.
        ........
          r1209375 | boday | 2011-12-02 01:59:57 -0500 (Fri, 02 Dec 2011) | 1 line
          
          CAMEL-4539 added camel-solr rollback operation support
        ........
          r1209391 | davsclaus | 2011-12-02 05:43:03 -0500 (Fri, 02 Dec 2011) | 1 line
          
          CAMEL-4539: Polished and fixed so using log4j logging.
        ........
          r1209392 | davsclaus | 2011-12-02 05:43:29 -0500 (Fri, 02 Dec 2011) | 1 line
          
          Added svn ignore
        ........
          r1209403 | davsclaus | 2011-12-02 05:58:53 -0500 (Fri, 02 Dec 2011) | 1 line
          
          Polished
        ........
          r1209404 | davsclaus | 2011-12-02 06:01:22 -0500 (Fri, 02 Dec 2011) | 1 line
          
          CAMEL-4715: Added more callbacks to RoutePolicy. Thanks to Bilgin for the patch.
        ........
          r1209457 | davsclaus | 2011-12-02 08:21:09 -0500 (Fri, 02 Dec 2011) | 1 line
          
          polished
        ........
          r1209585 | dkulp | 2011-12-02 12:03:07 -0500 (Fri, 02 Dec 2011) | 2 lines
          
          Add a BUNCH of svn properties to all the files to make sure eolstyle, mime type, etc... are all set and svn:ignores are all set on directories with poms and such.
        ........
          r1209589 | dkulp | 2011-12-02 12:10:06 -0500 (Fri, 02 Dec 2011) | 3 lines
          
          Add Apache license headers to files missing it
          Fix FileToFtpsWithFtpClientConfigRefTest to use separate FTPClient
          things for to and from since they aren't thread safe.
        ........

        J. Daniel Kulp <dkulp@apache.org> committed 7ffbdc6c335a4c4b2bef4e954d083542929acb9a (0 files)
        Reviews: none

        Blocked revisions 1203887,1205724,1206054-1206055,1206115,1206397,1206424,1206429,1206431-1206432,1206456,1206461,1206470,1206659,1206967,1207000,1207097,1207287,1208298,1208443,1208903,1208953,1209005,1209178-1209179,1209333,1209353,1209375,1209391-1209392,1209403-1209404,1209457,1209585,1209589 via svnmerge
        ........
          r1203887 | cmueller | 2011-11-18 17:33:19 -0500 (Fri, 18 Nov 2011) | 1 line
          
          CAMEL-4695: Calling the camel-smpp component results in a NullPointerException
        ........
          r1205724 | hadrian | 2011-11-24 00:21:00 -0500 (Thu, 24 Nov 2011) | 1 line
          
          CAMEL-4709. Disable failing hawtdb osgi test
        ........
          r1206054 | ningjiang | 2011-11-24 23:11:18 -0500 (Thu, 24 Nov 2011) | 1 line
          
          Using the cxf-jaxb feature to install the xml related api bundles
        ........
          r1206055 | ningjiang | 2011-11-24 23:13:30 -0500 (Thu, 24 Nov 2011) | 1 line
          
          Added a dynamic route test based on the user forum.
        ........
          r1206115 | ningjiang | 2011-11-25 05:31:36 -0500 (Fri, 25 Nov 2011) | 1 line
          
          Removed the System.out.println of the test
        ........
          r1206397 | hadrian | 2011-11-25 23:22:09 -0500 (Fri, 25 Nov 2011) | 1 line
          
          Minor improvement around test time and use logging instead of system out
        ........
          r1206424 | davsclaus | 2011-11-26 05:36:16 -0500 (Sat, 26 Nov 2011) | 1 line
          
          CAMEL-4514: Added onRemove callback to RoutePolicy. Thanks to Bilgin for the patch.
        ........
          r1206429 | davsclaus | 2011-11-26 06:40:14 -0500 (Sat, 26 Nov 2011) | 1 line
          
          CAMEL-4574: Log and Tracer have maxChars at 10000 by default to avoid logging very big data.
        ........
          r1206431 | davsclaus | 2011-11-26 07:22:00 -0500 (Sat, 26 Nov 2011) | 1 line
          
          CAMEL-4161: camel-mail no longer dep on Spring JARs.
        ........
          r1206432 | davsclaus | 2011-11-26 07:43:37 -0500 (Sat, 26 Nov 2011) | 1 line
          
          camel-mybatis feature not dep on spring
        ........
          r1206456 | davsclaus | 2011-11-26 10:15:28 -0500 (Sat, 26 Nov 2011) | 1 line
          
          CAMEL-4716: Polished camel-quickfix to remove dep on Spring JAR
        ........
          r1206461 | davsclaus | 2011-11-26 10:44:32 -0500 (Sat, 26 Nov 2011) | 1 line
          
          CAMEL-4716: camel-quickfix no longer depend on Spring JARs.
        ........
          r1206470 | davsclaus | 2011-11-26 11:05:01 -0500 (Sat, 26 Nov 2011) | 1 line
          
          Removed not needed Spring JAR dep.
        ........
          r1206659 | hadrian | 2011-11-26 22:26:31 -0500 (Sat, 26 Nov 2011) | 1 line
          
          Minor tests fix, test generated files should go in target/
        ........
          r1206967 | ningjiang | 2011-11-27 22:45:38 -0500 (Sun, 27 Nov 2011) | 1 line
          
          CAMEL-4714 Improvements to camel-example-cxf-tomcat sample
        ........
          r1207000 | ningjiang | 2011-11-28 02:28:09 -0500 (Mon, 28 Nov 2011) | 1 line
          
          CAMEL-4714 revert the change which remove the version of the war
        ........
          r1207097 | jstrachan | 2011-11-28 07:12:10 -0500 (Mon, 28 Nov 2011) | 1 line
          
          Fixes CAMEL-4719 so camel-web works better inside WebLogic; avoiding the use of the scalate console unless its present and in debig mode and having a precompiled error page to avoid unnecessary runtime compilation of scalate templates. Also used the simpler scalate filter which adds support for jade, markdown, confluence etc easier with less boilerplate XML in web.xml
        ........
          r1207287 | ningjiang | 2011-11-28 10:16:45 -0500 (Mon, 28 Nov 2011) | 1 line
          
          Clean up the camel-scala unit tests
        ........
          r1208298 | ningjiang | 2011-11-30 01:50:26 -0500 (Wed, 30 Nov 2011) | 1 line
          
          CAMEL-4728 Add setDefaultEndpoint method on the interface of ProducerTemplate
        ........
          r1208443 | ningjiang | 2011-11-30 09:12:09 -0500 (Wed, 30 Nov 2011) | 1 line
          
          Fixed the svn:ignore property issue of camel-jclouds
        ........
          r1208903 | dvaleri | 2011-11-30 19:13:30 -0500 (Wed, 30 Nov 2011) | 1 line
          
          [CAMEL-4720] Add support for Camel JSSE Configuration Util to FTPS component.
        ........
          r1208953 | hadrian | 2011-12-01 00:07:50 -0500 (Thu, 01 Dec 2011) | 1 line
          
          Minor test fixes
        ........
          r1209005 | ningjiang | 2011-12-01 03:54:13 -0500 (Thu, 01 Dec 2011) | 1 line
          
          Fix a CS error of camel-itest
        ........
          r1209178 | davsclaus | 2011-12-01 13:46:45 -0500 (Thu, 01 Dec 2011) | 1 line
          
          Upgraded to zookeeper 3.3.4
        ........
          r1209179 | davsclaus | 2011-12-01 13:48:06 -0500 (Thu, 01 Dec 2011) | 1 line
          
          CAMEL-4722: Polished example. Thanks to Glen Mazza for the patch.
        ........
          r1209333 | boday | 2011-12-01 21:33:04 -0500 (Thu, 01 Dec 2011) | 1 line
          
          CAMEL-4539: adds the camel-solr component (thanks to Alex Cowell and Bilgin Ibryam for the initial patch). enhancements added to include more Solr operations and Karaf features support
        ........
          r1209353 | hadrian | 2011-12-01 22:32:42 -0500 (Thu, 01 Dec 2011) | 1 line
          
          CAMEL-3371. Reopened issue and temporarily commented out failing tests.
        ........
          r1209375 | boday | 2011-12-02 01:59:57 -0500 (Fri, 02 Dec 2011) | 1 line
          
          CAMEL-4539 added camel-solr rollback operation support
        ........
          r1209391 | davsclaus | 2011-12-02 05:43:03 -0500 (Fri, 02 Dec 2011) | 1 line
          
          CAMEL-4539: Polished and fixed so using log4j logging.
        ........
          r1209392 | davsclaus | 2011-12-02 05:43:29 -0500 (Fri, 02 Dec 2011) | 1 line
          
          Added svn ignore
        ........
          r1209403 | davsclaus | 2011-12-02 05:58:53 -0500 (Fri, 02 Dec 2011) | 1 line
          
          Polished
        ........
          r1209404 | davsclaus | 2011-12-02 06:01:22 -0500 (Fri, 02 Dec 2011) | 1 line
          
          CAMEL-4715: Added more callbacks to RoutePolicy. Thanks to Bilgin for the patch.
        ........
          r1209457 | davsclaus | 2011-12-02 08:21:09 -0500 (Fri, 02 Dec 2011) | 1 line
          
          polished
        ........
          r1209585 | dkulp | 2011-12-02 12:03:07 -0500 (Fri, 02 Dec 2011) | 2 lines
          
          Add a BUNCH of svn properties to all the files to make sure eolstyle, mime type, etc... are all set and svn:ignores are all set on directories with poms and such.
        ........
          r1209589 | dkulp | 2011-12-02 12:10:06 -0500 (Fri, 02 Dec 2011) | 3 lines
          
          Add Apache license headers to files missing it
          Fix FileToFtpsWithFtpClientConfigRefTest to use separate FTPClient
          things for to and from since they aren't thread safe.
        ........


        git-svn-id: https://svn.apache.org/repos/asf/camel/branches/camel-2.8.x@1222333 13f79535-47bb-0310-9956-ffa450edef68

        Christian Müller made changes -
        Status Open [ 1 ] Closed [ 6 ]
        Resolution Fixed [ 1 ]
        Christian Müller made changes -
        Field Original Value New Value
        Affects Version/s 2.8.2 [ 12317866 ]
        Christian Mueller <cmueller@apache.org> committed caaed11b95901794ad224b6784b805d91718f119 (2 files)
        Christian Müller created issue -

          People

          • Assignee:
            Christian Müller
            Reporter:
            Christian Müller
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development