Camel
  1. Camel
  2. CAMEL-4658

Camel 2.9.0 SNAPSHOT not start on OSGI apache karaf

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.8.3, 2.9.0
    • Component/s: karaf
    • Labels:
      None
    • Estimated Complexity:
      Unknown

      Description

      Compiling my project is done using maven pluggins
      maven-dependency-plugin and features-maven-plugin.
      First unpack apache-karaf-2.2.3.zip.
      The second component uses mvn:org.apache.camel.karaf/apache-camel/$

      { camel-version }

      /xml/features

      karaf-version = 2.2.3
      camel-version = 2.9.0-SNAPSHOT (build 2011-11-10)

      Establish the following set of components

      <feature version='${karaf-version}'>ssh</feature>
      <feature version='${karaf-version}'>config</feature>
      <feature version='${karaf-version}'>webconsole</feature>
      <feature version='${karaf-version}'>wrapper</feature>
      
      <feature version='${camel-version}'>camel-blueprint</feature>
      <feature version='${camel-version}'>camel-ftp</feature>
      <feature version='${camel-version}'>camel-http</feature>
      <feature version='${camel-version}'>camel-http4</feature>
      <feature version='${camel-version}'>camel-quartz</feature>
      

      After starting karaf error log $

      {karaf.data}

      /log/karag.log

      2011-11-10 16:19:51,128 | ERROR | Thread-6                                                           | FeaturesServiceImpl              | s.internal.Features
      ServiceImpl$1  977 | 11 - org.apache.karaf.features.core - 2.2.3 | Error installing boot features
      java.lang.Exception: Could not start bundle mvn:org.apache.camel.karaf/camel-karaf-commands/2.9.0-SNAPSHOT in feature(s) camel-core-2.9.0-SNAPSHOT: Unresolve
      d constraint in bundle org.apache.camel.karaf.camel-karaf-commands [95]: Unable to resolve 95.0: missing requirement [95.0] package; (&(package=org.apache.fe
      lix.gogo.commands)(version>=0.10.0)(!(version>=1.0.0)))
              at org.apache.karaf.features.internal.FeaturesServiceImpl.installFeatures(FeaturesServiceImpl.java:353)[11:org.apache.karaf.features.core:2.2.3]
              at org.apache.karaf.features.internal.FeaturesServiceImpl$1.run(FeaturesServiceImpl.java:975)[11:org.apache.karaf.features.core:2.2.3]
      Caused by: org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.camel.karaf.camel-karaf-commands [95]: Unable to resolve 95.0: miss
      ing requirement [95.0] package; (&(package=org.apache.felix.gogo.commands)(version>=0.10.0)(!(version>=1.0.0)))
      

      We must add a dependency on a component in a file features.xml

      Camel 2.8.1 and 2.7.0 to work correctly.

        Issue Links

          Activity

            People

            • Assignee:
              Claus Ibsen
              Reporter:
              Aleksey Sushko
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development