Camel
  1. Camel
  2. CAMEL-4533

NPE thrown when connection is null loses root cause

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.8.1
    • Fix Version/s: 2.8.2, 2.9.0
    • Component/s: camel-jdbc
    • Labels:
      None
    • Patch Info:
      Patch Available
    • Estimated Complexity:
      Unknown

      Description

      When attempting to run a query against a datasource to which a connection could not be established, the attempt to rollback the transaction (which has not yet started) causes an NPE to be thrown which loses the root cause exception thrown by the driver

      1. camel-4533.txt
        0.7 kB
        Stu Churchill

        Activity

        Jean-Baptiste Onofré added a comment -

        Fixed on trunk: revision 1182244.

        Jean-Baptiste Onofré added a comment -

        Fixed on camel-2.8.x: revision 1182245.


          People

          • Assignee:
            Jean-Baptiste Onofré
            Reporter:
            Stu Churchill
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development