Details

    • Type: Sub-task Sub-task
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.9.0
    • Component/s: camel-hazelcast
    • Labels:
      None
    • Patch Info:
      Patch Available
    • Estimated Complexity:
      Unknown
    1. CAMEL-4461-patch.txt
      7 kB
      Ioannis Canellos

      Activity

      Claus Ibsen made changes -
      Status Open [ 1 ] Resolved [ 5 ]
      Resolution Fixed [ 1 ]
      Claus Ibsen added a comment -

      Yes the test still passes. But wonder if any end users who use camel-hazelcast sees the same errors when shutting down?

      Ioannis Canellos added a comment -

      The first error is a warning that no custom hazelcast config is provided and that hazelcast fallbacks to the default settings.

      I think the second has to do with shutting down the hazelcast bundle. The test still passes, doesn't it?

      Claus Ibsen added a comment -

      Patch applied to trunk

      Claus Ibsen added a comment -

      There is some exceptions thrown by hazlecast trying to load its configuration file

      [RMI TCP Connection(1)-192.168.1.66] WARN com.hazelcast.config.XmlConfigBuilder - Could not find hazelcast.xml in classpath.
      Hazelcast will use hazelcast-default.xml config file in jar.
      
      [FelixDispatchQueue] WARN org.apache.aries.jmx - Task rejected for JMX Notification dispatch of event [org.osgi.framework.BundleEvent[source=org.apache.karaf.shell.log [80]]] - Dispatcher may have been shutdown
      ERROR: JarContent: Unable to read bytes. (java.lang.IllegalStateException: zip file closed)
      java.lang.IllegalStateException: zip file closed
      	at java.util.zip.ZipFile.ensureOpen(ZipFile.java:416)
      	at java.util.zip.ZipFile.getEntry(ZipFile.java:161)
      	at java.util.jar.JarFile.getEntry(JarFile.java:208)
      	at org.apache.felix.framework.util.JarFileX.getEntry(JarFileX.java:61)
      	at org.apache.felix.framework.cache.JarContent.getEntryAsBytes(JarContent.java:122)
      	at org.apache.felix.framework.ModuleImpl$ModuleClassLoader.findClass(ModuleImpl.java:1816)
      	at org.apache.felix.framework.ModuleImpl.findClassOrResourceByDelegation(ModuleImpl.java:727)
      	at org.apache.felix.framework.ModuleImpl.access$400(ModuleImpl.java:71)
      	at org.apache.felix.framework.ModuleImpl$ModuleClassLoader.loadClass(ModuleImpl.java:1768)
      	at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
      	at com.hazelcast.impl.ClientService$Worker.stop(ClientService.java:187)
      	at com.hazelcast.impl.ClientService.shutdown(ClientService.java:155)
      	at com.hazelcast.impl.Node.shutdown(Node.java:370)
      	at com.hazelcast.impl.Node.shutdown(Node.java:347)
      	at com.hazelcast.impl.Node$NodeShutdownHookThread.run(Node.java:535)
      Exception in thread "hz.ShutdownThread" java.lang.NoClassDefFoundError: com/hazelcast/impl/ClientService$Worker$1
      	at com.hazelcast.impl.ClientService$Worker.stop(ClientService.java:187)
      	at com.hazelcast.impl.ClientService.shutdown(ClientService.java:155)
      	at com.hazelcast.impl.Node.shutdown(Node.java:370)
      	at com.hazelcast.impl.Node.shutdown(Node.java:347)
      	at com.hazelcast.impl.Node$NodeShutdownHookThread.run(Node.java:535)
      Caused by: java.lang.ClassNotFoundException: com.hazelcast.impl.ClientService$Worker$1 not found by hazelcast [58]
      	at org.apache.felix.framework.ModuleImpl.findClassOrResourceByDelegation(ModuleImpl.java:787)
      	at org.apache.felix.framework.ModuleImpl.access$400(ModuleImpl.java:71)
      	at org.apache.felix.framework.ModuleImpl$ModuleClassLoader.loadClass(ModuleImpl.java:1768)
      	at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
      	... 5 more
      
      Ioannis Canellos made changes -
      Assignee Ioannis Canellos [ iocanel ]
      Patch Info [Patch Available]
      Ioannis Canellos made changes -
      Field Original Value New Value
      Attachment CAMEL-4461-patch.txt [ 12494918 ]
      Ioannis Canellos added a comment -

      Attaching some osgi integration tests for camel-hazelcat.

      Ioannis Canellos created issue -

        People

        • Assignee:
          Ioannis Canellos
          Reporter:
          Ioannis Canellos
        • Votes:
          0 Vote for this issue
          Watchers:
          0 Start watching this issue

          Dates

          • Created:
            Updated:
            Resolved:

            Development